InvoicePlane 1.5.0 Beta 4 - Please help testing!


#82

Not the best list but the only one: https://github.com/InvoicePlane/InvoicePlane/blob/v1.5.0/application/config/payment_gateways.php


#83

What can I do, if I don’t have an 1.4.10 database? Is there any workaround?

And the javascript/styling isn’t running under the /settings page.


#84

When I download the file from the link above that says Beta3, I get a file named ip_1.5.0-beta.2.zip. before I start testing with Beta3 I would be glad to hear from you if this is beta2 or beta3.

I found the correct beta 3 file by editing the link :wink:


#85

I was running a test environment with version 1.4.10 with two custom fields created for the customer.
During database migration (Beta3) i got the following error;

Error Number: 1064
You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '(client_id, client_custom_fieldid, client_custom_fieldvalue) ' at line 2
INSERT INTO (client_id, client_custom_fieldid, client_custom_fieldvalue) VALUES ( '1', ( SELECT custom_field_id FROM ip_custom_fields WHERE ip_custom_fields.custom_field_column = 'client_custom_aanhef' ), 'Beste' )
Filename: modules/setup/models/Mdl_setup.php
Line Number: 330

#86

@vectore You can also start without any previous version, just run the setup.
But please re-download the package as I fixed a wrong link.


#87

@denysvitali Could you take a look at this?


#88

I have the following options in my settings :

  • Generate the invoice number for draft invoices : No
  • Mark invoices as sent when PDF is generated : Yes

Whenever I create a new invoice, when I use the download pdf link in the topright menu, it does change my invoice status to sent, but my Invoice still doesn’t have any invoice number.
To properly get an invoice number, I need to manually save again the invoice with the sent status.

Is this behavior intended, or is there a way to set the invoice number as soon I click on the download pdf button ?


#89

I have error in savin email settings


#90

Hello all,

I am running a local (windows) test environment with version beta 3.
For me the language settings in General settings (Language = ‘Dutch’ ) did not work.
Every language setting dropdown menu item had a trailling “backslash”.
So I changed the code in “application\helpers\trans_helper.php” at line 103 from:
$languages[$i] = str_replace('/', '', $languages[$i]); to
$languages[$i] = str_replace(array('\\', '/'), '', $languages[$i]);.
Everything is working fine now.

Hope this can help someone…


#91

Issues:

  1. In settings - Projects: I enabled the project module, filled in the ‘Default hourly rate’ and saved it afterwards, the amount always disappears.
  2. The form/layout of Projects - +New is not properly aligned. See screenshow below.

Change request:
Is it possible to add a new “Modules” tab in “Settings” where all modules can be merged/grouped together and enabled or disabled if needed?
Candidates: Projects, Online Payment, Sumex and …?? modules to move to this “Modules” tab.


#92

Thanks for the hints.

Basically yes, however I won’t add this to this version as it’s too much work with a minimal outcome.


#93

The issues reported by @gruntzy and @VeRony were resolved. Thanks for your help! :slight_smile:


#94

Hi!

I just installed InvoicePlane 1.5.0 Beta3 and everything seems to be working great except for one issue.

After enabling Stripe as a payment processor, I created a test invoice and tried to pay it through InvoicePlane. When I click on Pay Now it comes back with a 404 page.

Here is my error log: https://paste.invoiceplane.com/view/86de6e84

I originally installed InvoicePlane from the zip file and then tried installing again directly from github on branch v1.5.0. I had the same problem with both installs.

I also noticed a minor issue on the 404 page itself. The stylesheet and image are not using the IP_URL I set in the config file but are instead using an absolute path. (My install is under a sub-directory - /billing - and not directly on the domain).

Any help would be appreciated!

Thanks,

Red


#95

Thanks, will take a look at it.


#96

When creating a new client, you can leave the birthdate field empty without error.
However, when editing this client, the birthdate field defaults to 0000-00-00, which leads to the following error when submitting the form :

A PHP Error was encountered
Severity: Error
Message: Call to a member function format() on boolean
Filename: helpers/date_helper.php
Line Number: 115

#97

Thanks, it’s fixed.

By the way did you tried the online payments?


#98

Thanx for the quick fix :slight_smile:
I did not try the online payments for now, and I am not sure I will. We are not using them at the moment and nothing is configured on our side to test it.


#99

When I create a new quote or even a new invoice the placeholder ‘None’ in the “Tax Rate” field is right aligned and the carret down sign is mixed with the placeholder ‘None’. Actually when you click in this Tax Rate field the selection field shows up as normal.
But when adding a new row nothing happens when I click in the same Tax Rate field! When adding new rows the same problem persists.
However when I save the Quote, the Tax Rate placeholder for the second row is now left aligned and everything works again.


#100

Select fields are now fixed.


#101

Just installed Beta 3 as fresh installation.

I created a new client. Saved it, then want to edit the client again to fill in his email-address and got the following error when saving:

An uncaught Exception was encountered

Type: Error

Message: Call to a member function format() on boolean

Filename: /html/ip/application/helpers/date_helper.php

Line Number: 115

Backtrace:

File: /html/ip/application/modules/clients/models/Mdl_clients.php
Line: 154
Function: date_to_mysql

File: /html/ip/application/libraries/MY_Form_validation.php
Line: 36
Function: run

File: /html/ip/application/core/MY_Model.php
Line: 377
Function: run

File: /html/ip/application/modules/clients/controllers/Clients.php
Line: 84
Function: run_validation

File: /html/ip/index.php
Line: 333
Function: require_once