InvoicePlane 1.5.0 Beta 4 - Please help testing!


#162

Hm, i investigated further.

If i choose 0% Tax (Switzerland) at the product item in the invoice and delete the 20% Tax which are at the bottom of the invoice (above the sum) then i get the error.

If i leave the 20% everything is fine. (maybe because the if clause is not true).

This code worked before, i noticed that there is singular and plural (rate and rates). Is this correct?
$invoice_tax_rate->tax_rate_id == xx

Or should it be:
$invoice_tax_rates->tax_rate_id == xx

If this is only an issue i have please tell me, than i will not post it here in this thread. But the if-clause worked perfect in beta3.


#163

Yes it must be the plural because there can be multiple tax rates for a single invoice.
$invoice_tax_rates


#164

Hi Kovah,

When I test the upgrade from 1.4.10 to 1.5 beta4 I cannot run setup. I get a http 500 error.
The steps I took to test the upgrade;

  1. I restored a valid 1.4.10 database and restored the 1.4.10 files to verify that everything worked.
  2. Then I deleted all the 1.4.10 files and copied the extracted beta 4 filestructure.
  3. Copied the ipconfig.php file that i used with beta 3 test.
  4. Renamed and editted htacces to .htacces and edited the line for the subdir.

The above procedure worked fine with the beta 3 package. To me it looks like the beta 4 package is not a complete package that can be used to test the upgrade in this way.
I am also missing some folders (Only see the application folder with its subfolders…

Regards, Benny.


#165

Could you please verify that there are files missing in the downlaoded .zip package?
If I extract the package I get the following structure:

If these files are present you may share any server logs with us. You may also enable the debug mode in the ipconfig.php file.


#166

Sorry. Must have been something wrong during downloading or unzipping. This time, after downloading again, the filestructure is complete. Sorry bothering you about this.


#167

I have a problem by creating a new product.
The product family works fine, but when i create a new product this DB error occurs.

A Database Error Occurred

Error Number: 1054

Unknown column ‘provider_name’ in ‘field list’

INSERT INTO ip_products (family_id, product_sku, product_name, product_description, product_price, unit_id, tax_rate_id, provider_name, purchase_price, product_tariff) VALUES (‘9’, ‘9000-0010’, ‘Portierung einer Telefonnummer’, ‘Portierung einer Telefonnummer’, ‘99’, NULL, NULL, ‘’, ‘65’, ‘’)

Filename: core/MY_Model.php

Line Number: 211


#168

I tested the migration 1.4.10 to 1.5 and it seems that the issue I found with the migration in beta 3 (id 84 - april 4.) has not been resolved yet.in beta 4.
A Database Error Occurred

Error Number: 1064

You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘‘ip_client_custom_new’ (client_id, client_custom_fieldid’ at line 1

INSERT INTO ‘ip_client_custom_new’ (client_id, client_custom_fieldid, client_custom_fieldvalue) VALUES ( ‘1’, ( SELECT custom_field_id FROM ip_custom_fields WHERE ip_custom_fields.custom_field_column = ‘client_custom_aanhef’ ), ‘Beste’ )

Filename: modules/setup/models/Mdl_setup.php

Line Number: 332


#169

That’s weird. The provider_name column exists in my setup. And I’m also able to add a new product after upgraing from 1.4.0 or in a fresh installation.


#170

This bug is now fixed. If you would like to test this you may replace the contents of application/modules/setup/models/Mdl_setup.php with these contents: updated Mdl_Setup.php file


#171

I also get the 404 Error after enabling payment via Paypal Express.

When i click on the “Pay now” button on the guest view url i get the 404 page.


#172

Did you try to pay the invoice while beoing logged into your main account?


#173

Yes.
Now i tried with two other browsers, where i am not logged in. But i get the same 404.


#174

And did you tried to open the page while being logged in as a gust user for the corresponding client? Because you need to be logged in as a gust to process the payment.


@graffito @RedSerenityDev
Could you please post more details about how the URL looks like and what is displayed?

I tried this with a fresh install, my development version and an upgraded version from 1.4.10. If I view an invoice in the public guest view (e.g. http://test.dev/index.php/guest/view/invoice/o1aQa1vVh2K1WjO) the invoice is displayed normaly.
If i click the Pay Now button (which is a link to http://test.dev/index.php/guest/payment_information/form/o1aQa1vVh2K1WjO) I get redirected to the login page. No 404 errors in any way…


#175

I just noticed, that it is required to be logged in as a guest user for payments. It would be very good to display a login page instead of the 404 if a user clicks on the “Pay now” button and is not logged in.

So, i created a guest user, assigned the client and tested it again with the invoice i made before (is it a problem, that the invoice was made before the guest user was created?). Because the 404 is still here.

Guest url is:
http://xxxx.tld/guest/view/invoice/UgbXN2TpVZB8arC

When i click the button the url is:
http:/xxxx.tld/guest/payment_information/form/UgbXN2TpVZB8arC

And i see the red 404 page there…

I can provide you the actual urls and guest login via PM if you want. Just demo data there.


#176

Hm… may be an issue with removing the index.php part. I will try this again.

@graffito Could you send me detals via PM?


#177

Thanks Kovah. I replaced the Mdl_setup file and the migration went fine. The custom fields are there. I will do some testing with beta4 and keep you updated.


#178

I will check it in my database.

thx

— EDIT
I have fixed the missing field in my DB.
Now the text provider_name is the content of the discription.

I cant add a new title without tax.
If i add one without tax, a db error occours.


#179

The solution for the problem with the NULL value, and for another minor “optical” error.
EDIT:
And the solution for a little problem with the family_id.

/modules/products/model/Mdl_products.php

-121 $db_array[‘family_id’] = (empty($db_array[‘family_id’]) ? null : $db_array[‘family_id’]);
+121 $db_array[‘family_id’] = (empty($db_array[‘family_id’]) ? “0” : $db_array[‘family_id’]);

-123 $db_array[‘tax_rate_id’] = (empty($db_array[‘tax_rate_id’]) ? null : $db_array[‘tax_rate_id’]);
+123 $db_array[‘tax_rate_id’] = (empty($db_array[‘tax_rate_id’]) ? “0” : $db_array[‘tax_rate_id’]);
+124 $db_array[‘product_tariff’] = (empty($db_array[‘product_tariff’]) ? null : $db_array[‘product_tariff’]);


#180

Upgraded/migrated from 1.4.10 -> 1.5.0 beta4 (after the Mdl_setup.php modification)

======================================================

Create Invoice from customer list (Options) does not work. Create Qoute does.

======================================================

Once a Default Country has been set in General Settings, it cannot be reset to none.

======================================================

When I do a payment, I cannot change the payment method. The payment method is fixed to the payment method set when the invoice was created. In my opinion it should be possible to change the payment method when the payment is done.

======================================================

It’s not realy an issue but when creating a new user, the fields password and verify password are in the ‘wrong’ order. Maybe only in the dutch translation (???)

======================================================

After creating a guest useraccount and logging in with this guest account, I see Pay Now buttons on the Invoices.
I have no Payment Provider configured so I did not expect to see this button.
When pushing the Pay Now button I get a 404 error.

======================================================

After configuring a Payment Provider (System Settings > Online Payment) disabling (uncheck whatever option) is not possible.

======================================================


#182

The bug is already fixed, see the issue list in the first post for a fix.
All other reports will be investigated.