InvoicePlane 1.5.0 Beta 4 - Please help testing!


#21

Awesome work guys!

Is this being developed alongside IPv2.0?


#22

Strings are not at Crowdin. Yesterday I have completed Czech language, but have not found them.


#23

I imported the latest file into Crowdin. Please notice that the used strings may already exist for a longer time as the module was added several months ago


#24

Hi, I would be glad to test the 1.50 beta. I’m running 1.4.10 now on a testserver. What is the correct way to upgrade from 1.4.10 to 1.50 beta?


#25

The same like you upgrade from all other versions. Just notice that you have to edit some settings for the ipconfig.php file. See the feature list for more information.


#26

Hi Kovah,

I did the upgrade and it looks the upgrade succeeded. All invoices are still available :slight_smile:
However I see this PHP-error after the upgrade;

A PHP Error was encountered
Severity: Notice

Message: Constant MB_ENABLED already defined

Filename: core/MY_Utf8.php

Line Number: 65

Backtrace:

File: /home/my-domain/domains/my-domain.com/public_html/testfact/application/core/MY_Utf8.php
Line: 65
Function: _error_handler

File: /home/my-domain/domains/my-domain.com/public_html/testfact/index.php
Line: 333
Function: require_once


#27

Another thing I found was that the first e-mail I tried to send after the upgrade, gave a message: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

After resetting the SMTP-password the next e-mail was okay.


#28

Please delete the MyUTF8.php file from the application/core/ folder


#29

I tested recurrent invoices.
I set three invoices recurrent and these were generated as concept invoices by the cronjob.
I expected these invoices to be sent automaticaly but they were not.
The setting to send recurrent invoices automagicaly was set to No where it was set to Yes in the previous version.
When I set it to Yes then after I Save this setting it returned to No.

Found the following in the list of known issues: Some settings revert back to “no” automatically. [Fixed for Beta2]

So I will wait for Beta 2 before testing recurrent invoices.


#30

When I list the customers and click the options button for a certain customer to create an invoice, the create invoice window opens. However the customer shown in this window is not the selected customer but always the first customer in the list. I would expect to see the selected customer here.


#31

When doing a payment on one invoice, all invoices change status to Paid.


#32

When an invoice already has been created as recurrent, the same invoice can again be made recurrent. Is this intentionally?


#33

I still see a lot of strange things. For some reason I think it is a local issue…

When I create a new invoice (invoicenumber 31 for example) it has status Concept (dutch language). When I change the status to Viewed the invoicenumber changed to 27 and so i created a duplicate invoice number. The original invoice 27 was a Paid invoice.


#34

@Benny54 Please merge all future posts into one. There is an edit button where you can add content to an existing post.

To answer your posts:
some things will be fixed or already fixed for the second beta. Like the changing of the paid status for all invocies.

The strange behaviour you see for invoice numbers is not strange at all. it it the future that real invoice numbers are generated for a certain status. If you enable the option in the settings, there is no invoice number generated for an invoice, instead the internal database id (31 in your example) is used. If you change the status, the real invoice number is generated and changes to the appropriate ID (27 in your example). You may change the default Invoice group to see a real difference between the two numbers.


#35

Hi there,

first of all, thanks for the new version - it looks a lot better than the old one.
But if I wanna download/create a PDF invoice, I get a lot of PHP errors. I’m running PHP 7.

Some examples:

A PHP Error was encountered
Severity: Notice
Message: Undefined index: s
Filename: src/Tag.php
Line Number: 1639

A PHP Error was encountered
Severity: Notice
Message: Undefined offset: 11
Filename: src/Mpdf.php
Line Number: 17117

I ran composer install and npm install before.

Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Package operations: 8 installs, 0 updates, 0 removals
  - Installing codeigniter/framework (3.1.3): Loading from cache
  - Installing setasign/fpdi (1.6.1): Loading from cache
  - Installing psr/log (1.0.2): Loading from cache
  - Installing mpdf/mpdf (dev-development b36767b): Cloning b36767b45d from cache
  - Installing phpmailer/phpmailer (v5.2.22): Loading from cache
  - Installing setasign/fpdf (1.8.1): Loading from cache
  - Installing setasign/fpdi-fpdf (1.6.1): Loading from cache
  - Installing vlucas/phpdotenv (v2.4.0): Loading from cache
codeigniter/framework suggests installing paragonie/random_compat (Provides better randomness in PHP 5.x)
setasign/fpdi suggests installing setasign/fpdi-tcpdf (Use this package to automatically evaluate dependencies to TCPDF.)
phpmailer/phpmailer suggests installing league/oauth2-google (Needed for Google XOAUTH2 authentication)
Generating autoload files

#36

Hello,
First of all a big thank you for this new version. I use since 2-3 invoiceplane. It is both simple and effective. The improvements you make are really good.
Here is my problem. I installed version 1.5 without any problem but by testing I observed a bug at the level of sending by mail. Whether in php mail, sendmail or smtp, I still get the error message: “An Error Was Encountered - The action you have requested is not allowed.”. On the old version I have no worries.
A solution? Thank you
cordially


#37

The Undefined offset: 11 errors by mPDF can be ignored. They are internal issues with the HTML to PDF conversion but do not affect the app itself.


#38

Hello,

I have noticed the following things :

  • Credit invoices don’t take the global discount of the original invoice in consideration.
  • I get an error on the new client form : Severity: Error --> Call to a member function format() on boolean application/helpers/date_helper.php 86

#39

About the second error: it was fixed in the latest commits. If you want you can clone @Kovah v1.5.0 branch and test it out :slight_smile:


#41

You should rename the language files for different languages in the Language Repo.

Unable to load the requested language file: language/German/gateway_lang.php

And if I want to change the logo, I’ll get the following error:

A PHP Error was encountered

Severity: 8192

Message: Function mcrypt_get_iv_size() is deprecated

Filename: libraries/Encrypt.php

Line Number: 298

Backtrace:

File: /www/htdocs/xxx/application/modules/settings/controllers/Settings.php
Line: 59
Function: encode