Unable to send emails


I have installed the latest version of the IP and I cant seem to be able to send the generated quotes/invoice.
I have used all options. PHpMail, SendMail and SMTP (using the host and also a transactional email vendor)
When i click on send email I get a blank white page.

Any ideas ?

1 Like

Hi @mariushamilton

I believe this is a bug (mail with empty body). It works for me with smtp and some text within the mail body. With an empty body I will get a blank page too.

Kind regards, Proxymus

I tried. Same result.

Anyone else ???

Also blank page.

Thousands of lines of errors in the log, and no solution.

If this will get resolved, will be so nice.

Hi there, I have the same problem here. I created an email template, and I trying to send it via SMTP with gmail, but no results. it end up in a blank page. The thing is that I tried also with the other systems Send mail and PHP mail and either these ones work. Any clue? Thank you

Did you tried turning on the debug mode and taking a look at the logs as recommended in the FAQ?

Yes. Problems is that the logfile has thousands of line errors…

Please save them on a pastebin site like https://paste.invoiceplane.com/ and share the link here.
Without any error logs nobody will be able to help.

I’m having the same problem. In version 1.4.3 this feature worked fine for me. I completed a successful upgrade to 1.4.8 and now it will not send invoices over email. I have confirmed email setting are correct in the System Setting module.
Here is a link to the error log:

I will admit I don’t know much about what I’m seeing, however I suspect this line (which repeats and repeats at exactly the time I attempt to send email invoices) is the culprit: invoice/application/helpers/mpdf/classes/cssmgr.php 1067

mPDF is really a pain in the ass to work with. These logs are horrible actually. However, seems to be a problem with Undefined property: mPDF::$hasOC

Any news on how to fix this problem? :wink:
Tried all email settings, even tried to send it without PDF attachment.

Could you also post your logs? May be different problems for each user.

I will send them to you directly, it think I will take to much from the page here

Hi Kovah, Thank you for your time.
I don’t think I know what that is telling me. The PDF attachment (which is the invoice itself, generated by InvoicePlane) has some issue? The InvoicePlane PHP class that converts html to PDF has a problem?

Logfile right here : http://pastebin.com/GqP4727b

I’ve selected everything in between opening the dashboard and trying to send an email (no attachment option selected).
Just FYI, I have no problems with downloading PDF files generated by InvoicePlane, using the same custom template.

Same problem, sending mail with any of SMTP/Sendmail/PHPmail leads to HTTP 500 error. Here is the log: https://paste.invoiceplane.com/view/ca13ea9a

It appears the problem started after upgrading from 1.4.6 to 1.4.8

Hi there , in the recent version of invoice plane , there are quite few bugs. One of them is the mailing module (PHPMAILER). The white page error is caused due to the following :
Fatal error: Call to undefined method PHPMailer::trans() in /application/modules/mailer/helpers/phpmailer/class.phpmailer.php on line 1237
Hope they will fix this issue the soonest.


If so @Muhammad_Sheik then the problem seems to be related to: $this->trans(’<>’)
Which I guess is a translation library. There is one defined and included elsewhere with: $this->load->helper(‘trans’);
But I don’t know if that is present here in PHPMailer or indeed if this is the area where the problem actually is.
@Muhammad_Sheik how did you manage to track it here?
@Kovah any help with this would be much appreciated.