Installation database error

Hi there,

I’m getting the following error after copying files to local apache server and navigating to install path:

Unable to connect to your database server using the provided settings.
Filename: /var/www/invoices/third_party/MX/Loader.php
Line Number: 99

There is no mention of the database setup steps in the install instructions.

I’ve looked at threads like this ,but theres no mention of how to set up the DB
-> [Solved] Sub directory install - need help editing .htaccess

I’ve installed in the sub-dir /invoices

Here is my adjusted .htaccess file for sub domain use:

RewriteEngine on
RewriteBase /invoices
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . index.php [L]

Any help will be greatly appreciated.


Did you opened the installer with

thanks for the quick reply Kovah.

I should have mentioned that I tried navigating to /invoices/setup = 404 error

thank for the reply.

I reviewed this thread previously too.

My mod rewrite is enabled
Htaccess is in place.

Not exactly sure where of how to “AllowOverride is set to None but it has to be All” is it in apache2.conf or something?

This depends how your system is configured. Best practise: google on how to set AllowOverride

thanks for the replies mate.

looks like this software is a bit to complicated to install for an enduser like myself. Shame It looks very good.

Appreciate your efforts though.

thank you

Well it’s not more complicated than installing other applications like Drupal or even Wordpress who use basic URL rewriting. If the setup is not working your webserver is simply not configured correctly and changing this one value should only take up to 2 minutes.

Not to be funny but it must be a little more complicated. I’ve installed multiple instances of WP, opencart and joomla myself on our office server, but cant get this working.

I have googled what you have described and adding the required code to “allow” in both the htaccess and or the apache2.conf isn’t solving the error unfortunately.

If anyone has some hands on experience fixing this issue, I’d love to know.


Throwing 500 internal server error once Allow All is added.

If must be AllowOverride All

Yes, I was just abbreviating.

thx for trying. I have found another open source solution that works right away.

I’m still interested to find out the problem, whenI have more time. Haven’t encountered this before.

I’m having the same issue. My subdirectory is invoice. I’ve rewrote the htaccess, i created test.php to see the configuration it does not show mod_rewrite in there, but when I contacted customer service (A2 Hosting) they said it’s already enabled with all account. I won’t give up I really like this software looks amazing, great work.

I figure it out :wink:

I have the same errors.

My Case is:
Here is where InvoicePlane files =

I’ve done the following:
1- The .htaccess in should NOT has the RewriteBase /invoices
2- The .htaccess in should has the “RewriteBase /invoices”.
3- Write the URL like this:

Congratulations :smile:

Hope this help somebody

1 Like

Can you please share Which other solution you have found
I bet there is nothing better than invoiceplane

Anas_Ahmar’s solution worked for me. Thanks!

i have try that but didn’t work

facing this error

Unable to connect to your database server using the provided settings.

Filename: /hermes/bosoraweb070/b1479/ipg.cwica/unitedmobile/invoices/third_party/MX/Loader.php

Line Number: 99