Unable to migrate from fusion invoice

Used the migration tool which worked and was successful.

Replaced all the files with invoice plane. Made a backup of old files, and db before doing this.

I keep getting db errors looking for fields that do not exist…

That sounds linke you didnt run the updates for InvoicePlane.
Please open yourdomain.com/setup Abd follow the instructions.

I do that and it works and says successfully configured… Then I reload and it goes to /setup/upgrade_tables with the following error…

Error Number: 1060

Duplicate column name 'email_template_type'

# VAT ID and VAT Code added (see #76)
ALTER TABLE `ip_email_templates`
ADD COLUMN `email_template_type` VARCHAR(255) NULL
AFTER `email_template_title`,
ADD COLUMN `email_template_subject` VARCHAR(255) NULL
AFTER `email_template_body`,
ADD COLUMN `email_template_from_name` VARCHAR(255) NULL
AFTER `email_template_subject`,
ADD COLUMN `email_template_from_email` VARCHAR(255) NULL
AFTER `email_template_from_name`,
ADD COLUMN `email_template_cc` VARCHAR(255) NULL
AFTER `email_template_from_email`,
ADD COLUMN `email_template_bcc` VARCHAR(255) NULL
AFTER `email_template_cc`,
ADD COLUMN `email_template_pdf_template` VARCHAR(255) NULL
AFTER `email_template_bcc`;

Filename: /home3/bowenac/public_html/invoicing/modules/setup/models/mdl_setup.php

Line Number: 94

Hello sir i copy all fills in www/invoice
& i want to start in localhost but
error is show 500 internal server error…
plz help me…

When I try to go to the dashboard I get

Error Number: 1054
Unknown column ‘ip_invoices.invoice_status_id’ in ‘field list’

SELECT ip_invoices.invoice_status_id, (CASE
ip_invoices.invoice_status_id WHEN 4 THEN
SUM(ip_invoice_amounts.invoice_paid) ELSE
SUM(ip_invoice_amounts.invoice_balance) END) AS sum_total, COUNT(*) AS
num_total
FROM ip_invoice_amounts
JOIN ip_invoices ON ip_invoices.invoice_id =
ip_invoice_amounts.invoice_id
AND MONTH(ip_invoices.invoice_date_created) =
MONTH(NOW())
AND YEAR(ip_invoices.invoice_date_created) =
YEAR(NOW())
GROUP BY ip_invoices.invoice_status_id

Filename: /home3/bowenac/public_html/invoicing/modules/invoices/models/mdl_invoice_amounts.php
Line Number: 275

The conversion tool is really not working correctly. I just did a fresh clean install of invoiceplane, with a new db etc. Fresh install works fine. Drop the tables of new db after a fresh install, import the sql backup from fusion invoice, the migration tool doesn’t make it all the way through the steps and ends up causing an error.

I guess I will just manually create all my invoices unless there is another way of doing it quicker or someone knows of a solution… I still have my fusioninvoice running as I installed plane on a new subdomain.

Maybe something changed on the latest release of plane that the migration tool is failing with… Just a note I am using fusion invoice v 1.2.4

Maybe I can write a script to update the tables from the other db…

The migration tool should work correctly if you run the database upgrades after the conversion but I’ll take a look at this.

Let me know if you would like access or do a join session so you can see it first hand.

Any update on this?

No sorry, forget to take a look.

I tried it a few times again today and had the same issue, ended up going through all the errors and removing duplicate columns in the tables etc, and it kept recreating the same columns.

I then decided to double check all the tables, from tables of a fresh copy of invoiceplane. The migration tool isn’t creating all of the columns for some tables. I went through and manually created some of the columns and it is now working.

I have noticed that the guest url is not working for the invoices though, it just loads a blank page, I will look into that more.

I also have some suggestions on some features that I will probably add myself but think they should be implemented.

Well, the IP Migration tool does not create any tables and should not create ones. The tool just makes preparations for the InvoicePlane Setup to run all upgrades, nothing more.

Sorry to bring back an old post, but I’m having similar issues. The migration script (from what I can tell) just renames the fi_TABLENAME to ip_TABLENAME and changes up the version numbering in one of the tables. However, a new Plane setup has database fields that Fusion doesn’t.

So is the installation method

  1. Install InvoicePlane
  2. Run IP setup
  3. Run migration tool

Or am I missing something?

The migration tool simply doesn’t work… well I should say fully work.

Sounds like you ran into the same issue and possibly from an older version of fusion.

What I did was installed a fresh version of invoice plane, exported the db.
Then compare the db tables to the imported tables, and add the missing columns manually via phpmyadmin or what ever else you are using. Just work through it and it will eventually work. If I remember correctly there were only a handfull of columns that were missing.

And you are correct all it does is rename the table names, and then the upgrade doesn’t check if the columns exist which it should, and add them if they don’t…

They should update the migration tool page explaining this or update fusion invoice update script to check if all the columns needed for fusion exist and if not then create them.

Thats not how it’s written in the wiki

  1. Run the migration tool on your old FusionInvoice database.
  2. Open the InvoicePlane setup and connect to this database.
  3. Let the setup run all updates and enter new information if necessary.

If everything is done you should be able to log in to InvoicePlane.

And yes it’s correct: after running the migration tool the database does not look like the InvoicePlane database but that’s why you have to run the installer again which upgrades all tables to the latest version.

I’m telling you when I ran it, I did it like 10 times and it would always fail after running the setup again when updating because it was missing fields. After manually adding the needed db fields, I was then able to run the setup again and the update completed etc…

That worked for me. I probably got out of order somewhere. To anyone following behind, here’s what I did. I believe I was coming from FusionInvoice v1.3.5

  1. Backup everything in case it goes badly
  2. Completely remove FusionInvoice (clear out the whole folder, leave the database alone)
  3. Download and unzip the migration tool
  4. Run migration tool against FusionInvoice database
  5. Delete migration tool (basically emptying out that folder again)
  6. Download and unzip InvoicePlane
  7. Run InvoicePlane setup
  8. Enjoy InvoicePlane

Thanks Kovah!

1 Like