GuestURL gets 404 Error

When I try to send invoice, the guestURL which is generated is not accessable, I get 404 error.

guest URL:

404 Page Not Found

The page you requested was not found.

Any setting I am missing ?

Without any info about your setup it’s hard to tell.
But I guess it mostly is due to the .htaccess. Did you set it up right and can you provide some logs from your webserver?

My htaccess file content:

## Run InvoicePlane in a subfolder
## If you are using a subfolder please remove the hash in front of the line ‘#RewriteBase /subfolder’
## and replace ‘subfolder’ with the actual name of your folder, i.e. ‘RewriteBase /invoices’

<IfModule mod_rewrite.c>

  RewriteEngine On
  #RewriteBase /subfolder
  RewriteRule ^index\.php$ - [L]
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule . /index.php [L]
  ## Remove the hash in front of the following two lines if you want to force HTTPS
  #RewriteCond %{HTTPS} off
  #RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]

Do not know where to look at error logs on my hostinger shared server. Enabled log error but still do not see error folder in my file manager.

invoice guest URL:

Without logs it’s nearly impossible to debug it.

You are using LiteSpeed, I don’t know if this require additional configuration or so. Please use Apache if possible.

Did you rename the htaccess to .htaccess (leading DOT)? This is required to make the htaccess work.

htaccess has been renamed to .htaccess

I tried contacting the hosting provider to see how to disable litespeed.