Impossible to start the setup. Error 404

Hello everyone.

I am deploying InvoicePlane on my Synology NAS server but I can’t get it to work.

From the Web Station utility I create a host server where I indicate the folder where the InvoicePlane files are, I indicate to use Apache and PHP 7.4, also I have granted read and write permissions on the folder.

When I click on start I open the browser and I get an error 404 page not found. I change the welcome by setup and same result.
I add before the /index.php the name of the folder, same result.

I have modified the htaccess file (be careful that it is not .htaccess) I add the subfolder in case it was that, nothing, same result error 404.

I also edited the ipconfig.php and added IP_URL= and nothing.

I don’t know what to do anymore to start the setup.

I also had problems with Inovice Ninja and got it to work, but I want to use Invoice Plane for comparison.


You will need to rename the htaccess file to .htaccess and put it in your rootdirectory to make Apache beeing able to work with it.

Hi @M4rt1n

I think I did (in one of many tests) and it didn’t work.

Anyway I try again and update.


I keep getting the 404 error.

If you look at the url when I put the address /setup it redirected me to /setup/language but I still get the 404 error.

Where did you download your installation from? GitHub or the official download site?

Also I would need a Log for debug, otherwise helping is hard


I downloaded it from the official website. Try to download the GitHub version?

Where can I get the log?
I’m using Synology’s Web Station (DSM 7), I don’t know where to find the log.


Thats the correct version then.

Please google how to getthe logs from a Syno. But please make sue you have installed Apache and all the other requirements. (REQUIREMENTS)

Please share a screenshot from your rootdirectory, so i can check everything is as it should be.

I’ll figure out how to get the logs.

Apache and extensions are installed. As I mentioned earlier I am testing billing solutions and Invoice Ninja (both version 4 and version 5) if I managed to make it work using Apache.

Attach screenshot root directory (/web/invoiceplane).

The it ofc does not work. This is not how WebServers work.

You need to adjust your URL and your settings to your setup.

Please try:

Thanks for the help.

Believe me, I’ve tried several ways to format the URL.

As I mentioned at the beginning, I get the URL /setup to be redirected to /setup/language (if it does this redirection is that the server is responding) but the error 404 appears.

For this reason, it ruled out a URL formatting issue because it does the language selection redirection (first step of the configuration).

You also need to modify the .htaccess to now fit your subdirectory.

Edited on .htaccess indicating the directory and nothing, everything remains the same.

I’m configuring a Raspberry to use docker and I hope to have more luck, because from the Synology there is no way.