Payment failed. Please try again. Sending credit card numbers directly to the Stripe API is generally unsafe. We suggest you use test tokens that map to the test card you are using, see https://stripe.com/docs/testing

Under settings > System settings, I added stripe as the online payment method with the following details:
API Key ==> I used stripe secret key
Currency ==> USD
Online Payment Method ==> Credit card.

When I go to invoices > view invoices > options > Edit and use the Guest URL to make a payment with stripe, I get the below error:

Payment failed. Please try again.
Sending credit card numbers directly to the Stripe API is generally unsafe. We suggest you use test tokens that map to the test card you are using, see https://stripe.com/docs/testing.

What could be the step I am missing to correct my configuration?