Setup Not Showing CSS

My setup isn’t showing as a GUI and just as a basic HTML Page as seen in the screenshot attached, does anyone know why this is and how to fix it? I think its something to do with permissions but I’m not sure.


Well this can happen if you do have XSS problems.
May you have set your IP_URL to a url with HTTP but actually accessing it by HTTPS

For any further debug please open the developer console (in your Browser) and post the errors/warnings here.

Hey! Ive forced https in .htaccess and changed the IP_URL to HTTPS but now it says has redirected too many times.

Well these are just way to less infos to say anything…
please post:

  1. your Domain
  2. InvoicePlane Version
  3. ServerOS
  4. PHP version
  5. Webserver (Apache/Nginx…?)

Also answer these questions:

  • have you actually installed a valid SSL Certificate?
  • are you trying to use InvoicePlane on a Domain-Root or a subfolder?
  • are you using any type or reverseProxy or CDN like CloudFlare?

my domain is
The latest version
Ubuntu 18.04
PHP 7.4

Yes, i have used certbot, on a domain-root also yes i am using cloudflare, i always have done with other sites and there has been no hassle.

You do have a 301 redirect. Thats not good.

  1. What exactly is your .htaccess?
  2. Tell me what SSL Mode you have CloudFlare in? Flexible?
  3. Any PageRules in CloudFlare that apply to the billing subdomain?

About (2.) No matter what it is: it should be “Full (Strict)

.htaccess: ## Run InvoicePlane in a subfolder## If you are using a subfolder please remov -
It is flexible, but ill change it to full strict.
And no, i have no page rules at all.

Now the page works again, but its text based again

You will have to set it to Full, or FullStrict!
Otherwise it will access your Server trough HTTP and not HTTPS, then your Server redirects to HTTPS and it goes on in a circle, thats whay you had a redirection Loop

Ok I see the HTTPS URL works now.

May you want to tell me where exactly you did get the Application?
The official site or GitHub?

If you downloaded (the sourcecode!) from Github please download it from HERE:

Hi i got it from github, I followed a tutorial: Install Invoice Plane on Ubuntu 16.04 | 18.04 with Apache2, MariaDB and PHP 7.1 • Website for Students

I started on step 5, since i have everything else done

It is now Full(Strict)

Do not download the sourcecode, just use the Artifact we builded for the community.

This turorial is shit … sorry. It will not work, everyone folliwing this will get into the same problem like you.

Please read and follow the official DOCS and follow the installation

Oh xD. Ill do the official one and see how that goes :slight_smile:

Please do so, thanks!

Do not forget to report back :wink:

Will do :slight_smile:

Hey! It now works, I forced HTTPS on .htaccess then it showed the text based thing again, so i commented it out again and now it works with the GUI based setup :slight_smile:

on the setup it didnt allow me to make a user…

Now it did

Nice to hear. Anyway you should really not comment that out. As most probably your Server now again (behind CloudFlare) answeres the requests in plain HTTP and not encrypted in HTTPS.

Better try to make it work with HTTPS and SSL Mode Full or Full Strict.

In the end you will transfer your sensible datas through this configuration, so better care about security :slight_smile:

Its on full(strict) and I have a cerbot certificate on my server & its running on 443 on the site .conf :slight_smile:

1 Like

Very good! Then the .htaccess force HTTPS should work aswell Better turn it on. But thats just a recommendation.

Also: please flush the whole CloudFlare Cache to make sure it will not refetch all requested URLs as otherwise it can cause missbehaviours as some CSS files before have not been accessable and will be stored in CLoudFlare as a 404 Error.

Now have fun with your new Online-Invoicing Tool :slight_smile:

thanks for the help! :slight_smile: