Invoices Display Incorrect/Cached? Values on Phones Only


Recently an installation of InvoicePlane I admin began “not saving” values to invoices. This is how it appeared to the user, but when I had a look I noticed on a laptop the values changed in the invoice were being saved to the database and were displaying correctly on the laptop.

On 2 different phones, I was seeing the incorrect … I want to say “cached” … value.

Software details:

IP installed on webhosting
PHP Version: 5.6.40
IP Version: 1.4.8

Software on laptop
Windows 10 OS Version 1909 (Build 18363.1379)
Microsoft Edge 88.0.705.74 (Official build) (64-bit)

Software on both phones
Android 10 QKQ1.191215.002 SDK=12451000
Microsoft Edge 77.0.3865.116 (Developer Build) unknown (64-bit)

The browsers on the phones are the latest version of Edge for Android available from the Play Store in our location.

Tried clearing browsing data on the phone in Edge but still gets the same result. It’s like there’s a cached version somewhere, but when I tried on my phone as well, it seems to be pulling a cached version also.

I verified the value stored in the database for the invoice when my phone loaded the ‘cached’ value and the database showed the value the laptop displays.

Is there anything I can check to fix or troubleshoot this?

Let’s try 2 things:

  1. Incognito browser in Chrome or Firefox on the several environments
  2. consider upgrading to Ip 1.5.11, caution: you need PHP 7!

I tried InPrivate mode on the phone.

After first log in, the phone displayed the correct value as was in the database. I edited the value on the phone and saved. The value didn’t change on the phone.

I then loaded the dashboard on the laptop, the change made on the phone was seen on the laptop. So the phone is able to edit the value, the edition is then not seen on the phone when the page reloads.

I altered the value on the laptop, the change was not seen on the phone.

I closed the InPrivate tab on the phone, reopened it, relogged in, and still the change is not seen.

The value i’m changing is the Due Date field.

It’s very strange, and I think I’m going to update to the latest version when I get time.

1 Like


I have installed the latest version. I backed up the invoiceplane database via phpmyadmin and made copies of the .sql file on different drives.

I did pre-initial run configuration of the htacess file for running from a subdirectory and ran initial setup. Everything seemed to work fine.

I was then presented with the login screen, and I logged in using the account login from the previous installation. It is returning a message saying “There is no account registered with this Email address.”

The setup said the database tables were upgraded successfully. How do I log in if the previous user accounts are not available?

Additionally on the topic of this thread, this afternoon my wife tried updating invoice values on her laptop and it was not working. It was acting like the phones are. Only my laptop shows the updated values. Her laptop and my laptop are running the same version of Windows 10 and the same version of Edge. She installed Chrome and tried with that and got the same result. We’re running through the same router and I can’t find any cache options on the router. We connect to the wifi and get DHCP assigned IP on both laptops. No idea why it works on my laptop and not other devices.


Seems that the browser’s auto-fill option for the form was putting the wrong email address in (at least I think that’s what happened) . I looked at the users entry in the database table and found it was a different email address to what I thought. Seems like everything is working. Have to test on the phones.

Everything seems to be working now.

If it fails, update it. That’s how software seems to work these days.

It’s extremely difficult to replicate the problems.

The steps to replicate are excellent, but you need an installation of 1.4.8 and then an upgrade to 1.5.11 to replicate it.

Usually I install my InvoicePlane locally, so I can look around, do a test upgrade, things like that.

I assume you did the upgrade on the live server?

I will re-read all the steps you did and I hope that you upgraded from 1.4.x to 1.5.x doing every single version?

See if you can install InvoicePlane locally (using docker) that will help with troubleshooting

1 Like

True that. v1.4.8 is really old now please update to a tleast 1.5 versions.
Next thing is:
if problems occure we need logs to trace down the errors. I never heared of this error. But if the browser does not display values or does not show that it saved it there most probably will be some logs in the dev-concole. Please provide them to us and we can debug this.
If it works on a Laptop I think everything is right with the server and the installation, because if the problem would be there it would occurre everywhere.

As you edited your answer please tell us if the problem is finaly and absolutely fixed so we know.

Hm yes kind of even if it sounds stupid :slight_smile:
From v1.5.10 to 1.5.11 we did some heavy code cleanups and updated depenedecies. As browsers from time to time change behaviours and mark functions and methods as deprecated they will sooner or later delete them. Thats why we also update dependencies to updated them to a state which users can as long as possible use them.
I think that it was a problem of frontend dependencies as they sometimes vary on how they work from type of device to another type of device.
Next time we mostly have to do that again. So get dependencies up to date to make this project which isnt the youngest still rocksolid even now!

@Cabji your feedback would be appreciated and please tell us if everything works now

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.