InvoicePlane 1.5.11 released

A new release of the InvoicePlane application is available: v1.5.11
You can download the latest version from the InvoicePlane website.

Update Guide | Changelog


This is a maintain release that add PHP 7.4 functionality to InvoicePlane and fixes a few security issues.

1 Like

This Update specially adresses the need for PHP 7.4 support which a lot of the community wanted. Supporting PHP 7.4 (which is the latest PHP 7 version) will give this project the base it needs and makes it more future proof.

We have successfully tested this version on these PHP versions:

  • PHP 5.6
  • PHP 7.0
  • PHP 7.1
  • PHP 7.2
  • PHP 7.3
  • PHP 7.4

Adding all Threads/Posts which asked for PHP 7.4 or this is related to
Thread8657 @djmarya, Thread8568 @amesso, Thread8569 @Laurens.

Also in the Slack channel some people asked about, so we hope you gyus can test v1.5.11 soon and report back how your experience with the new Update is.

1 Like

Great job! Upgraded and all seems to work fine again. Thanks for the continued efforts!

Hi I did a fresh install of IP 1.5.11 on PHP 7.3 and all was fine. When i upgraded PHP to version 7.4 i got the following error on the logon page and on several other pages:

A PHP Error was encountered
Severity: Core Warning
Message: Module ‘sqlite3’ already loaded
Filename: Unknown
Line Number: 0
Backtrace:

My hosting company is using a PHP selector under DirectAdmin and here sqlite3 is selected by default in PHP 7.4… After deselecting sqlite3 in the PHP selector the errormessage disappeared.
Problem solved :wink: