InvoicePlane 1.5.10 released

A new release of the InvoicePlane application is available: v1.5.10
You can download the latest version from the InvoicePlane website.

Update Guide | Changelog


This is a “back on track” release that mainly brings IP back to life and up to date. Also fixes some security issues.


:beetle: Known bugs in version 1.5.10

  • this release does not get shown at “System” => “Update” so you will have to install it without seeing it there. The cause or this behaviour already got fixed.
  • additionally also the known Issue from the PreRelease applys here (LINK)
2 Likes

I have been using 1.4.8 how do i upgrade from 1.4.8 to 1.5.10 and my PHP version is 7.0.3

The Update Guide is very clear on how to update.
If you do have any issues by following the guide pls tell us what exactly did not work.

The guide also mentions a special part where is written what to do when comming from a lower version then 1.5.0 ==> Upgrade to InvoicePlane 1.5.0 from a previous version

#edit: also I deleted all of your duplicated messages in slack. Pls just ask once. This is not a commercial service, so you may have to wait untill someone answers.

2 Likes

Hello Martin, thanks a lot for keeping this app alive. It’s sure worth the time and energy you spend on it.

I just wanted to let you know that I upgraded my 157 tot 1510 yesterday. I also installed PHP v7.4.2 for the occasion. I noticed that mPDF did no longer work for PHP v742. Something to do with the use of {}.

Uploading the latest version of mPDF from Github did the trick.

I would need to be careful with automated upgrades from now on I guess…

I’m on Windows Server 2019. Just FYI. Thanks again.

We internally also have tested and made the next release since 2 weeks (v1.5.11) which will be PHP compatible.
We are now testing it extinsively so nothing is wrong.

Pls be patient, we will release it soon

Hello,
The first thing is already well done for all the efforts you made to keep this application alive.
I just installed version 1.5.10. There is a small language bug. If you select the application settings and choose a language (I tested several), the translation is done in part for the general tab but for the others it always remains in English. Similarly, the drop-down menu for settings also remains in English. And last thing in the selection of settings the menu bar which was for me in French is put in English. I checked in the translation file and there are all the words translated. Any solution to solve this problem?
Otherwise a small suggestion: It is possible in a next version to put a search engine at the product level?!
Good luck and long life to Invoiceplan :slight_smile:


Pls change the Language here to take global effect:

Right Top Menu > Person Icon > Language

Pls try changing it there and report back.