Installation error autoload.php


#1

I’m did everything explained, but I’m getting the following error:

PHP Fatal error: require(): Failed opening required ‘vendor/autoload.php’ (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’) in /home/nmapyoas/public_html/programa/index.php on line 18

Any help would be appreciated.


#2

Seems like you have a PHP mis configuration.

Could you check which PHP version you are using?

Or did you use the master version from Github?


#3

Rerun the composer config

composer install


#4

Unfortunately i do not have WHM access only Cpanel so I don’t know how can i do that vie Cpanel


#5

I tried with 5.4, 5.6, 7.1,7.2 and it is the same.


#6

Which version of InvoicePlane did you installed?

Or could you point me to the location of that file you downloaded?


#7

This is the location I downloaded from.


#8

I tried with different hosting i have, still the same error.


#9

Could you please check if there is a vendor/ folder existing in your InvoicePlane root path ?


#10

No, there is not


#11

Would you mind to download InvoicePlane from here and give it a try ?


#12

Thank you very much. I just tried and everything works as it should.
THANK YOU! Problem solved.


#13

The only thing missing is Macedonian language. If there is a way for me to install it? I spend a lot of time contributing to that macedonian translation :slight_smile:


#14

Add another language is simple and easy to start, you could copy the whole folder application/language/english/ to application/language/[YOUR LANGUAGE] and it will show as an Language option in setting page.

Hope this helps :slight_smile:


#15

@Ivan_Kartov the PHP version on your server is really old.
Good that you got InvoicePlane working but now set the server to PHP 7.2 and then see if it still works ok


#16

I did that and everything works fine. Thank you all of you for helping me fix this.