SMTP email error


#1

Unable to send emails error message - SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

After saving system settings the SMTP Password is not shown.

Where are the email system settings saved?

Installed on windows 10 - InvoicePlane V1.5.9 with xampp v7.1.32-0-VC14.
Also tried xampp v7.3.9 gives the same error.


#2

Go to the system settings and click the “Email” tab.

You will have to select the email delivery method for the settings fields to be reserved.


#3

The SMTP email settings have been set in the system settings email tab.

The settings displayed when reopening Security -> Security Settings -> Email

  • Attach Quote/Invoice on email? - Yes
  • Email Sending Method - SMTP
  • SMTP Server Address - smtp.isp (isp not actual value)
  • SMTP Sender Address for system emails - MyName@isp (not actual name)
  • Requires Authentication - No
  • SMTP Username - MyName@isp (not actual name)
  • SMTP Password - this is always blank when I reopen settings
  • SMTP Port - 25
  • Security - None
  • Verify SMTP certificates - No

The above settings work in my email client but not in Invoice Plane.

The password entry value in the data file is missing. What is the data filed name where the email settings are stored so that I can enter the password there?


#4

It is stored in the database

select * from ip_settings where setting_key like "%smtp%" ;


#5

@crafter, thanks, I have looked at all the database.* and config.* files and don’t find select * from ip_settings where setting_key like "%smtp%" ; What is the name of the database that I must look at.


#6

Pay attention.

I said it was in the database, not in any (config) files.

Run that query against database that you configured when you installed IP to see the current values.