ERROR 404: Not Found cron


#1

Version 1.5.9

I cannot get my cron job to run for recurring. I am getting the error below, with my domain and key replaced with a place holder. My cron command is:

wget -O - http://mydomain/invoices/cron/recur/mykey > test.txt 2>&1

–2019-09-05 18:21:01-- http://mydomain/invoices/cron/recur/mykey
Resolving mydomain (mydomain)… 96.30.192.22
Connecting to mydomain (mydomain)|96.30.192.22|:80… connected.
HTTP request sent, awaiting response… 404 Not Found
2019-09-05 18:21:01 ERROR 404: Not Found.

I have read through all of the postings with a 404 error and have tried all of the suggestions but still get the error above from the cron output.

I have also tried running this directly from the browser but I get:

Not Found

The requested URL was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Any help would be appreciated.


#2

My cron is the same, running on a subdomain. PHP 7.3.9 and no problems. But I’m on a dedicated machine;

0 0 * * * wget -O - https://mydomain/invoices/cron/recur/mykey >/dev/null 2>&1

So any info about OS, and firewall might help a bit.

What is the output of
netstat -lan | egrep LISTEN

and
iptables --list
for example?

It might be that firewall rules in place that are blocking port 80 outbound, or refusing the reciprocal inbound response

It also can be your hoster and that they have some firewall rules, so if you use a hosterer ask them…


#3

Try http://mydomain/index,php/invoices/cron/recur/mykey