Failure with database installation


#1

I have a failure when installing InvoicePlane on my mutualised OVH Web Hosting Pro plan. I tried using localhost or the name I’ve choosen for my DB name but still fails.

Here is the DEBUG Pastebin. Safari’s console is not printing anything, even when I reload the page.

I installed Invoice Plane in a subfolder and edited the .htaccess like told in the Wiki and I have a Wordpress install on the root. Might be the problem ?

Thanks in advance for your help.

PS : Couldn’t get an activation email (to create an account here) until trying with a third one.


#2

Update : I just tried to install InvoicePlane on my older website (with a different web hosting) and it was smooth as f***.

I’m now wondering if I should transfer my domain to the older web hoster or if I can still install it on the new one. I messaged them as well but still no answer either.


#3

hey @Coucouille2 welcome to the forum man!
Which PHP version are you running on your mutualised OVH Web Hosting Pro plan
Which PHP version are you running on localhost?
If you know docker install laradock. I would stick with PHP 7.1 on your localhost for now.
The install of InvoicePlane 1.5.9 should be smoothly.


#4

Thanks! @UnderDog

My OVH one is PHP 7.0 & MYSQL v.5.6

About localhost I tried to set that up following this tutorial : https://websitebeaver.com/set-up-localhost-on-macos-high-sierra-apache-mysql-and-php-7-with-sslhttps

But had problems with Sequels. Then found a topic on Stack Overflow about the problem and someone talked about Docker.

So I made an account and tried to install Docker but I’m stuck on step 3 (Now let’s build and tag a Docker image.) When I launched Docker the first time it asked for user privileges, clicked yes then nothing.
And now when I try to launch it again, nothing happens.

I get a “No such file or directory” when pasting the instruction from Docker website :

cd doodle/cheers2019 &&

docker build -t username/cheers2019 .

Hope I wasn’t too reckless, I kinda blindly followed instructions.

However when I hit localhost on Safari, I get PHP Version 7.1.23.


#5

Ok I would love to help you out with docker on MacOS, but that can get quite frustrating, because it needs a lot of extra steps on Mac.

Your PHP version is awesome, so let’s fix things on the server first.
What you need to do is turn debug modus everywhere. I’ll be back to tell you how


#6

I just managed to get Docker working. Just pushed my first repository. I also received feedback from my web hoster and they told me that I should use MariaDB but it’s not available with their mutualised options.
So I guess I’d have to use my older website server.