Setup stuck at setup/language - always redirects to language setup page


#1

Hello,

my site finance.velonto.at is stuck at the setup/language page. I have no adblocker on and the js is running fine with no errors in the console.

I am using Godaddy shared hosting

This is my ipconfig.php file:
<?php exit('No direct script ac cess allowed'); ?>
# InvoicePlane Configuration File

### START HERE
# Set your URL without trailing slash here, e.g. http://your-domain.com
# If you use a subdomain, use http://subdomain.your-domain.com
# If you use a subfolder, use http://your-domain.com/subfolder
IP_URL=HIDDEN

# Having problems? Enable debug by changing the value to 'true' to enable advanced logging
ENABLE_DEBUG=true

# Set this setting to 'true' if you want to disable the setup for security purposes
DISABLE_SETUP=false

# To remove index.php from the URL, set this setting to 'true'.
# Please notice the additional instructions in the htaccess file!
REMOVE_INDEXPHP=false

# These database settings are set during the initial setup
DB_HOSTNAME=
DB_USERNAME=
DB_PASSWORD=
DB_DATABASE=
DB_PORT=

# If you want to be logged out after closing your browser window, set this setting to 0 (ZERO).
# The number represents the amount of minutes after that IP will automatically log out users,
# the default is 10 days.
SESS_EXPIRATION=864000

# Enable the deletion of invoices
ENABLE_INVOICE_DELETION=false

# Disable the read-only mode for invoices
DISABLE_READ_ONLY=false

##
## DO NOT CHANGE ANY CONFIGURATION VALUES BELOW THIS LINE!
## =======================================================
##

# This key is automatically set after the first setup. Do not change it manually!
ENCRYPTION_KEY=
ENCRYPTION_CIPHER=AES-256

# Set to true after the initial setup
SETUP_COMPLETED=false

#2

Hi,
please remove the IP_URL from the config file in your topic. We don’t need it to solve your question :slight_smile:
Let’s see if i can help you. What if you installed Invoiceplane in English and then set your own language? Would that be an idea?
As soon as you set up invoiceplane on your host, can you make a screenshot of the page you’re stuck at?
For your information, I just installed Invoiceplane an hour ago, but that was not on a godaddy host, so we have to focus on what you’re seeing.


#3

A few questions

  • Are you installing in a subdirectory?
  • What PHP version are you using?
  • Did you check your permissions
  • What browser are you using?

It is possible that your session data is not being stored from the first screen to the second.


#4

We just had the same issue at the Slack channe some days agol:

your most probably running at the wrong PHP version. (5.4, 5.5 or 5.6)
Pls change to 7.1 (if possible) or 7.0

If this doen not help, pls provide the Infos asked by crafter ↓


#5

What ^^^ Martin says is correct of course except that I would not install PHP 7.0 anymore it’s too old and most likely unsupported, that’s why they made PHP 7.1 so quickly.
Focus on that PHP version, it will be the key to solutions of some of the problems


#6

The queries you asked resolve my issue. Thanks dear