Broken Installation


#1

I was using v1.5.8 on Ubuntu and when my Ubuntu crashed, I was able to backup my Invoiceplane database. I then installed v1.5.9 to a Windows system running Xampp 7.3.3 and restored the old data. The system seems to be working fine except that it randomly redirects to "/index.php/welcome - Please install invoiceplane " when I click on any link like ‘Create invoice’, ‘View client’ etc. When I go through the setup process again, it successfully upgrades the database tables but this problem does not get solved. I can sometimes access these links by retrying i.e. clicking ‘Back’ then click the link again. It can sometimes take a number of retries before the link opens.

I have tried a fresh install on a blank database and restoring only specific tables with my important data but does not help resolve the problem.

When I try to test the new installation without restoring old data, the problem seems not to occur. My old data is very important, how may I resolve this?
2z64n6


#2

This seems like a permissions issue potentially. Have you tried asking your question on our Slack channel?


#3

@cokwax there are lots of things to look at, you need specific step-by-step help, so let’s see if it will help to come to the slack channel.
Most important are 2 things:

  • config file: is it showing that ‘invoiceplane is installed’
  • sessions and temporary files: if it cannot write a session or a temporary file, it will most likely redirect to /index.php/welcome
    The trick is to do a little programming and logging on that page, so you can see what happened instead of that welcome page.

key is : “sessions”, but let’s see what my slack-colleagues think of that