Issues accessing invoiceplane via the web

Hello I have been using invoiceplane for many years now since the fusioninvoice days of it going retail. I have no problem creating invoices locally on my nas which is a webserver.

However I noticed when I tried to access the Http://server/web/ipfolder/index.php it does not work. within my lan yes it works fine ive done port forwarding and changing so the server is indeed reachable but i noticed i could not get the web server to work.

I thought maybe there’s something in the htaccess file that would allow me to access invoice plane remotely but I noticed i renamed the file for security purposes.

I did attempt to create a .htaccess file and put allow all just for testing purposes and that actually broke invoiceplane from being accessed locally on my lan.

So question 1 is do i need a htaccess for world wide web access to invoice plane?.

The device i am using to host my invoice plane is a synology nas running

“Does not work” could mean anything. Can you provide more details of what you expect and what you get.

As a quick check, did you change the URL setting in the ipconfig.php file?

hi yes what i mean by does not work is i get a error 404 the page you are looking for could not be found. I have not made any changes to the ipconfig.php. i tried but then the website shows up as locally 192.168.x.x/mydnsurl/invoiceplane/index.php instead of 192.168.x.x/invoiceplane/index.php/sessions/login so yeah messing with the ipconfig file breaks access to the invoiceplane server.

i even went this route and attempted this with no success.

The .htaccess file should not be aware of your IP address, unless you manually edited that.

From what you describe, the answer is in the ipconfig.php file. Make sure your application root path is correctly reflected in the config file.

I dont even know what to put for the ipconfig.php like i mentioned i tried one thing and it ended up breaking access to it.

What is your URL to the application, and what is in your URL.

Without any relevant information, any attempt to help you is just going to based on guesswork,

locally for my webserver is http://mysyno/INVPL/index.php/sessions/login if i do https all the graphics and texts becomes a real mess. but from a unc standpoint the path is \mysyno\web\INVPL

I guess you dont understand completely what you are doing there and just try to do something to make it work.

  1. without a SSL-Cert you cant call a https URL, as this will break a lot of things.
  2. if it works locally this is not the problem. you want to set it up on your server, right?
  3. what is your Domain?
  4. and where is it mapped?
  5. do you want to run IP from an subdirectory?

If you want to, you can PM me here and I will help you via TS/TeamViewer, whatever will help

hey martin. I agree with you regarding SSL which is why I dont use SSL since the self signed certificate isnt the same as a purchased SSL. domain is a ddns, this is all being hosted on a dchp assigned ip by the isp using a ddns name to point to this dchp wan facing ip address. ill pm you thanks for the reply :slight_smile:

Dear Sir
I am currently running 1.5.11
i am facing a similar issue accessing the IP , however
however, my issue is slightly different
i can access my IP from the WEB by setting a NAT and IP_URL pointing to the external url.
however, when i do so, i lost the access from my LAN, the CSS styling link pointed to external set in IP_URL and it tries to acces everything using the external url.

my setting as follows:
internal access http://172.x.x.106/ivplane

my external access:
Port forward 8888 to 80

when i set the IP_URL to external address, i can access it from web but i cant access it from LAN
when i set the IP_URL to internal address, ic an access from LAN, but i cant access it from Web

is there anything i did it wrong? or please advice me the correct setting so that i can access it from Both LAN at home and from Web when i travel out.

thanks in advance for all the helps
best regards

try to add both :slight_smile: