Cron job setup trouble


#1

Hi,

I generated a cron-key and handmade the following folder:
https://facturatie.wesaca.com/invoices/cron/recur/CRON-KEY
This folder has 755 permissions. If I browse to this folder, I get a 404 error.
After this I made a recurring invoice and added a cronjob according the manual.
Still I does not work. Anyone any tips?
THX Freek


#2

@crafter can you help with this one please?


#3

The issue looks resolved to me @UnderDog.


#4

I am testing it now. I will keep you informed. THX Freek


#5

It still does not work unfortunately.
I am a little confused. Do I make a file (cron key) in the invoices/cron/recur folder or do I make a folder named (cron key)? I tried both, setup recurring invoices (and the show up in the recurring invoices report) and made the cron job. Still no luck…
Freek


#6

This has the steps you need to take.
https://wiki.invoiceplane.com/en/1.5/modules/recurring-invoices

As a summary.

  • You need to create a key which you then keep a safe copy of. There is no need to save this onto a file. You decide the best way to remember the key. It will serve like a type of password (since you do not have to log in to use cron jobs).
  • You must then call the URL from your scheduling tool. This URL must include your key to tell the server this is a legitimate request.

The format of the URL is https://facturatie.wesaca.com/invoices/cron/recur/CRON-KEY (where we enter the key you created in the URL).


#7

Hi. It works now. There was an error in the Cron job. THX for the great support. Freek


#8

hi. I have the same problem. Hopefully someone can help.

This is my cron link https://preyes.net/ip/invoices/cron/recur/cronkey

I get a 404. Unlike yours which has Wrong cron key!
Not sure if there is a problem with the setting or have missed out something


#9

You main site url is https://preyes.net/ip/index.php

Therefore your cron site url must be

https://preyes.net/ip/index.php/invoices/cron/recur/cronkey