PHP Error after installation


#1

Hi Guys,

I am currently exploring and installed version 1.5.9 on my local computer, I was able to install and run the system but PHP error below won’t go away on the top of my screen. Not exactly sure what to do on it to disappear any help is much appreciated.

Locally Hosted Using XAMPP
Invoiceplane Version: 1.5.9


A PHP Error was encountered

Severity: 8192

Message: strpos(): Non-string needles will be interpreted as strings in the future. Use an explicit chr() call to preserve the current behavior

Filename: MX/Router.php

Line Number: 224

Backtrace:

File: C:\xampp\htdocs\ip\application\third_party\MX\Router.php
Line: 224
Function: strpos

File: C:\xampp\htdocs\ip\application\third_party\MX\Router.php
Line: 71
Function: set_class

File: C:\xampp\htdocs\ip\index.php
Line: 325
Function: require_once


#2

Are you using PHP 7.3 ?


#3

Was able to find a fix :https://github.com/InvoicePlane/InvoicePlane/pull/680#issuecomment-453630154