Downloading PDF


#1

Hello, I’m interested in using the InvoicePlane software, but when I’ve tested the demo version, I can’t download a PDF. Can anyone verify that the PDF download works on the current version.
Many Thanks,
Tim


#2

It does, and I use it all the time. The PDF download opens in a new window. What happens when you try and download - perhaps a little more detail will allow others here to offer assistance.


#3

Thanks for the response. I’m using the demo version at https://demo.invoiceplane.com/index.php/dashboard. When I select an invoice and try to download the PDF from options, it takes me to https://demo.invoiceplane.com/index.php/invoices/generate_pdf/31 and gives me the error message: “Failed to load PDF document.” I just wanted to make sure that others are having success with the software before downloading it for our use. Thanks so much for your input.


#4

I logged in, clicked on the first invoice and was able to see and download the invoice

https://demo.invoiceplane.com/index.php/invoices/view/27

https://demo.invoiceplane.com/index.php/invoices/generate_pdf/27


#5

Thanks! I tried it in another browser and it opened fine. May be an issue with my settings in Chrome. I’ll look into it. If you have any suggestions, I’d be grateful.


#6

I can indeed confirm that its not working in Chrome.
But this just happens in the Demo (v1.5.0)
On my own InvoicePlane installation (v1.5.9) everything is working fine.

Maybe time to update the Demo?

@thaas: just download it and try it, its working fine if you use the latest version :wink:


#7

Thanks for confirming that the latest version is working. I wonder if the issue on v1.5.0 involved extraneous bytes before %PDF in the file head, because Reader was telling me that the file was either not supported or damaged when I tried to open the download. We’re planning to do an install of v1.5.9 in the near future. I’m sure I’ll be back with more questions :grinning:. Thanks again.


#8

Amongst getting IP v1.5.10 ready, the hope is to update the demo at the same time.