HTTP to HTTPS, No longer can login?


#1

Hi!

First off, thank you for the wonderful software! this has been my go-to for a few years now and its excellent.

I recently upgraded my server to support HTTPS, when doing so my Invoice.mydomain.net no longer works. I get the login screen but nothing else works. The site was working great with plain HTTP prior to the change.

I’m not sure what steps to take next, I have been digging around looking for somewhere to add the HTTPS extension in some URL field or something but cant find anything.

|PHP|7.0.33|
|MySQL|5.6.41-84.1|


#2

Did you change the url in ipconfig.php and .htaccess files?


#3

I am unable to find the ipconfig.php anywhere (this is an old install).

The .htaccess file was working before but now I fear I have played with it too much.

I’m not sure if it’s possible to do a fresh install while linking to the existing database. But that might be the only easy option at this point.


#4

I would not do so, maybe this works maybe not but if you reinstall it you will lose every “user-data” on the ftp which are not included on a fresh installation like old invoices.
Pls follow this instructions:

1.) Make a Backup, yes even now.
2.) in your folder where invoice.mydomain.net maps to, search for the file “ipconfig.php”
3.) edit this file and append “https://” befor the domain at IP_URL
HINT: IP_URL=https://invoice.mydomain.net
4.) safe the file and try again loging in.
5.) if this will not help search for the file “README.rm”
6.) open it and read in the second line what version of InvoicePlane you are running at.
7.) pls tell us here which version your running at
8.) pls also turn on debug and tell us what your console and your log says.
9.) wait untill we will tell you what to do next :slight_smile:

Support here is free, for you and for us, so may wait a bit :+1: