Unable to load dynamic library (mcrypt)


#1

Hi.

Yesterday I installed InvoicePlane v1.5.9 on my Linux server (CentOS) managed with Plesk Onyx.

All right, but every time I go to the Dashboard or to any other part of the site, it sends me this message.

What I find very strange is that system tries to load a * .dll file, when it comes to an installation on a Linux server. Besides, I am using PHP 7.1 with mcrypt extension enabled. I guess it should not be happening, right?

Or is it normal?

What do you think this is due to?

What can I do to solve it?

Thanks in advance!

A PHP Error was encountered
Severity: Core Warning

Message: Unknown: Unable to load dynamic library '/opt/plesk/php/7.1/lib64/php/modules/php_mcrypt.dll' - /opt/plesk/php/7.1/lib64/php/modules/php_mcrypt.dll: cannot open shared object file: No such file or directory

Filename: Unknown

Line Number: 0

Backtrace:

#2

I sure that .dll file for Windows only. So, you’re config is wrong. Centos need to be load php_mcrypt.so


#3

Oh well, I already knew that.

What I need is a solution, not a diagnosis at a glance.

Thank you anyway.


#4

Hope this help


#5

Well, no.

As I said before, I already installed and enabled mcrypt in my Plesk server. Actually, InvoicePlane 1.5.9 is running just fine, but that warning.does not stop showing up. What I need is something that makes it go away.

Thanks once again!


#6

You are on a paid service - you should ask your supplier for assistance.

The message is clear - it is looking for a file that does not exist. That most likely is configured in your php,ini or related file. Find that file and either correct there or in the mcrypt.ini file.

As a sanity check, you should verify that mcrypr is indeed installed, using phpinfo() or php -m.


#7

Somehow you are pretty rude … at least this is how you sound to me. If you know where the problem is pls fix it.

This forum is not for paid support, everyone is here is using this forum and giving support in his/her free-time.
For paid support pls pay a supplier.


#8

Try edit opt/plesk/php/7.1/etc/php.ini . Find and remove the line that load .php_mcrypt.dll file.


#9

Nope, I am not on a paid service, but self hosted.

Sorry if my message sounded rude. Since English is not my mother language, this has always been an issue when communicating.

Regarding my problem, I could solve it by removing ;extension php_mcrypt.dll from php.ini, as quangbahoa previously suggested (thank you very much, by the way).

Sorry if I did not answer before, but we had a long weekend (national holiday) in Mexico.


closed #10