IP2.0 pdf output not working


#1

Hello,

I just download version 2 and setup went pretty good.
All is working but when I try to view the pdf invoice I get this error:

Whoops, looks like something went wrong.

I have set debug mode to on and the following came up:
1st line: Not implemented, please install iconv in InputStream.php line 80
And then a bunch of text errors.
I’m sure iconv is installed on my server. (all latest packages installed php/apache etct, etc)
An older version of IP is working fine.
Maybe adding mpdf back into the new version would be better?

Please help


#3

Thanks for you reply Peter121.

I guess you dont…
I have absolutely no problem with my router device.


#4

MY apologies @cdv, we’ve had a few issues with off topic responses recently, I will look into this with our IP2 team and see if we have a solution.

Regards


#5

No problem @Severenth, I hope there will be an solution realy like the 2.0 version!!


#6

@cdv wkhtmltopdf works great!

You can use it by going to System Settings > PDF and switching the PDF Driver there.

Installing it should be straightforward, you can find more details here https://wkhtmltopdf.org. Let me know if you need help setting it up :slight_smile:


#7

thanks @georgio!
I have done that before and even the directory where wkhtmltopdf is installed is set correct, I am then looking at a File not found error in my browser.
And I think there is not much to install because I am on a cpanel hosted service and have no root access. Any ideas?


#8

try downloading it again, maybe your download process was interrupted (https://routerlogin.mobi/192-168-10-1/) and you could not get the entire file.


#9

Thanks!!
But that did not help unfortunately…


#10

do you want to make it work with mpdf or with wkhtmltopdf? In case of mpdf i can see if @crafter can help you with the iconv error on your server…


#11

As far as I know, iconv should be on your PHP itself, in order words compiled and built in.

From the command line, typpe
php -m
and look for the existence of iconv.

Otherwise you may have to install a version for your OS that has iconv built in.


#12

Thanks for your input!!
Its working now incorrect settings iconv was the problem.

Thanks again!!


#13

Thanks for your input!!
Its working now incorrect settings iconv was the problem.


#14

Nicely done! Glad it helped, man!