Stuck in a Login loop invoiceplane 1.5.9


#1

Hi, I’ve been using invoiceplane for a few years now, I’m randomly having problems which I haven’t seen elsewhere on the forum so I need your help to resolve this please.

After logging on to invoiceplane the dashboard opens as normal with all of the correct information, if i click anything i’m instantly returned to the login page and have to put my credentials in again. Then after getting to the dashboard and clicking something I’m returned to the login page again… and this happens forever.

I tried to edit/delete .htaccess nothing changed, I tried to run setup, it keeps getting stuck on prerequisites and goes into a loop. I reinstalled invoiceplane in a different folder and I get the same login problem with the fresh installation, I reinstalled the current installation and the same problem still.

I checked the logs and there are no errors there


#2

had problems with mod_security in the past which sounds similar to your problem, do you have any sort of stricter firewall on your server?

otherwise how do your htaccess look like? especially the rewriting part?


#3

Im using a normal hosting server which uses cpanel, I could ask the admins to change some settings but need some guidance as to what to ask them.

my htaccess currently looks like this:

Remove index.php

RewriteEngine on
RewriteBase /sub-dir
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . index.php [L]


#4

is the rewritebase correct?

you usually set this to the subolder where invoiceplane is located at if it’s not within the same dir the domain is located at.

RewriteBase /
# if it's directly pointed towards a domain/subdomain

RewriteBase /ip/
# if it's located at domain.ext/ip

#5

It was incorrect, i’ve updated it as you have advised but I’m still getting the same error.


#6

Have you tried another browser?


#7

I tried another browser before but it was the same,

I emailed my hosting company and they resolved the issue:

Dear Sir,
We had looked at your script installation. It was the session issue; we have added the custom php.ini file and this has resolved this issue. Please test and report back.

Hope this helps anyone else who has this problem.

Thanks for your support.