Creating new module; pagination error


#1

Trying to create an additional module. Copied over “units” directory and created new tables for 'ip_foo" and ‘ip_foo_custom’.

I updated all files to reflect new table name/datya. When I navigate to ‘https://home.ivplane.com/index.php/foo’ I receive following pagination error:

Call to undefined method Mdl_foo::paginate()

As far as I can tell, everything in new code is correct so what is causing pagination error?

Your assistance is greatly appreciated. Thanks!


#2

Quick check for your class definition.

class Mdl_Foo extends Response_Model
{
   ...
}

Response model extends Form_Validation_Model which extends MY_Model where the paginate is defined.


#3

Worked like a charm! Wish my hard-headed a** would have posted earlier, would have saved me a day of rage quitting!

Thanks for the assist =)


#4

Lol, It often takes a second pair of eyes to point out in 10 seconds what you have been staring at in 10 hours. We all here to help each other. Glad it worked out for you.


#5

@citizenfoe whenever you have time, remember to mark @crafter post with the answer as “accepted answer” using the check-box button under the message.


#6

I’m looking for it, but I don’t see any checkbox for “mark as answered”…?


#7

:sweat_smile: The “Mark as solution” is not available in the dev discussion category