Blank settings page


#1

Hi,

I am new to invoice plane. After installation, I needed to configure, but when I open the page: http://127.0.1.1/invoiceplane/index.php/settings

I get a blank page. Am I doing something wrong or is there a fix for this?

Thank you n advance for your help in this matter.

Best regards


#2

A blank page is often an indication that there was some PHP error that is not showing due to the error settings.

Find the index.php file in you site home directory and add these lines.

ini_set('display_errors', 1);
error_reporting(E_ALL);

#3

Hi Crafter,

Thank you for you prompt response. I edited the file /var/www/html/invoiceplane/index.php

and pasted your suggestion. after saving, I stoppped and started the apache2 service to pick up the new configuration, but I get get nothing diffferent when I go back to Invoiceplane (blank settings page).

Did I miss something? Please advise at your earliest convenience.

Thank you


#4

Hi, it<s me again… I think that code made a log file in /invoiceplane/application/logs . At the end I saw an error:

`ERROR - 2018-10-08 13:07:25 --> Severity: Error --> Allowed memory size of 2097152 bytes exhausted (tried to allocate 544768 bytes) /var/www/html/invoiceplane/application/third_party/MX/Loader.php 412.`

But I am not sure if this is related to the problem.


#5

I think the log file is there because of the application settings, not the code changes.

The error you are seeing is due to php not having enough memory. This could be due to either your PHP settings, or a machine with low spec.

A limit of 2097152 is around 2 M which is very low.

You can change the limit in the same file by adding the line to set this to 16 M. You can try other values - 32, 64, 128, 256, 512, 1024 etc.
ini_set('memory_limit','16M');

As a last resort, but only to see if this is really the issue, not to fix (because this is a bad practice, try to set no limit.
ini_set('memory_limit', '-1')

You don’t have to restart apache. Just refresh the page.


#6

Thank you again for the prompt response. I have looked at /etc/php/7.1/apache2/php.ini

But I do not see ini_set('memory_limit' in that file. What file are you referring to? (pardon my newbie ignorance)

Best regards


#7

Please contact your server administrator or hosting provider to correctly set the memory limit. Please do not add any configuration lines into the InvoicePlane app.


#8

Hi Kovah,

Unfortunately, I am the “Administrator”


#9

You can set this on your file
/var/www/html/invoiceplane/index.php

If you want to change the php settings on the server itself, add in (or change) php,ini

memory_limit = 1024M


#10

You are correct @Kovah, The command I provided was to troubleshoot, not to fix.


#11

Thank you Crafter for your help. The page opens fine now.

Best regards