Error showing quotes on v1.3.1

Hello, I have a problem since I have updated my InvoicePlane version to 1.3.1

When I want to show a quote, InvoicePlane shows me that error:

The Encrypt library requires the Mcrypt extension.

It works at the previous version. Do I need to install something to make it works? Thank you.

That is strange, because the encryption should be removed in this version…besides… in V1.3.0 everything worked??

Sorry, the last version that I used was v1.2.1 but it worked good. I don’t know what is the problem with that new version.
It only happens with quotes, I can see invoices correctly.

Hey there,

there is one link to a library left in the file application/modules/quotes/controllers/quotes.php

In line 83 where it says “$this->load->library(‘encrypt’);” delete this line or comment this out! This should solve your problem!

As stated in the official wiki the mCrypt library should be installed and enabled:
You should install the library as it supports secure sessions.

I already have all the requeriments installed including mCrypt Extension but the problem still appearing. What can I do to solve it? Thank you.

as mentioned before, delete this line 83 :slight_smile:

It works. Thank you!

This topic was automatically closed 20 hours after the last reply. New replies are no longer allowed.