Disable Rounding


#1

Hello folks,

I have little problem to solved.

Ex. in the field price my client write 10,098.00 and the system will rounding the price in 10,10 value.

I also set in the settings decimal number like 3 but nothing change.

I need that all the number in fields stay without any rounding, it is possibile do this?

Someone can help me, thanks


#2

There have a few posts in the past week, and it is related to the separation of the currency and cents figure.

For example : Roundup Issue with Pending amount


#3

Hello Crafer,

Thanks…i see and read all post that you link me…but i don’t see same kind of problem… :frowning:


#4

Ex. in the field price my client write 10,098.00 and the system will rounding the price in 10,10 value.

Check the “Decimal Point” and “Thousand Separators” in the ‘System Settings | General Tab’ page.

I am sure you will find that you have defined the comma (",") as decimal point, which causes the number “10,098.00” to be read by the software as “ten comma zero nine eight…” and to be rounded to “ten comma ten”.

If you define a number format (i.e. the decimal point and thousand separators) you are expected to use that format when typing numbers.

I also set in the settings decimal number like 3 but nothing change.

Currently, the number of decimals in IP is fixed to 2 because it stores amounts in the database as decimal(20,2), that is, with two decimal digits, and all numbers are rounded accordingly to two decimal digits. For instance, these values

image

will become

image

I need that all the number in fields stay without any rounding, it is possibile do this?

No, if you type more than two decimal digits the number will be rounded when you save the form (quote, invoice, etc.). Having said that, in many cases, you can solve the problem by changing the product units. For instance, instead of selling kilograms of something at 0,01234 €/kg you could sell grams at 12,34 €/g.


Disabilitare Arrotondamenti