Can't create invoice without PDF password


#1

Hello,

I downloaded and installed v1.3.0 today (a fresh install). When I create an invoice, add a product and then click ‘save’ a PDF password is added automatically. In my system settings there’s no default PDF password defined.

How can I create an invoice without PDF password protection?

Thanks!


Password in quotes and invoices
#2

This is a bug with the password handling.

Open the file /application/modules/invoices/views/view.php
Replace line 43

invoice_password: $('#invoice_password').val(),

with

//invoice_password: $('#invoice_password').val(),

This disabled the password function temporarily, a fix for this will be released in the next days.

if you already added an invoice with a password you have to remove it directly from the database or replace it by an easy to remember password like “invoice” or something similar. Sorry for the inconvenience!


InvoicePlane v1.3.0 released
#3

Thank you so much for your rapid reply and the workaround description! I was able to deactivate the PDF password function following your description.


#4

I’m testing with a blank DB, doesn’t work also WITH and WITHOUT password in settings.

Thanks a lot for work!


#5

Hi there! The problem is related to your database kollation.

What Kollation did you setup? It should be UTF-8

Best regards


#6

Hi Pitma,

i check now and db is configured with utf8_general_ci

EDIT:
I clean totally database
I set utf8_general_ci
I configure a new installation of invoiceplane
I set password in settings (es. password)
When i save invoice after insert a row password is changed from “password” to “‘phZLVSuO00eYnTJldNI7J3Skqp5Ugt7A�]�V)�����’8uϧ��ja�M�C�9E%�yk�’”

What I’ve to do?

Thanks


#7

Did you changed the kollation after creating the database?


#8

New setup on a blank db after changed the Collation ti utf8…So:
-empty the db
-change collation
-setup invoice
-set password on settings
-new invoice with password
-save invoice
-the password is like posted before

:frowning:


#9

Kovah and I created a fix which we’re testing now! Should be available tomorrow!


#10

I realized that, to empty the db is not enough! For me it worked after creating a db directly in utf-8 but even this seems to be buggy! So best thing is wait for the hotfix :smile:

Best


#11

Thank’s a lot buddy.

I can’t delete and crete new db cause i’m on altervista hosting …

I’ll wait for fix

THANKS A LOT for awesome work.


#12

I just realized this problem also occurs with the quotes. Same fix but select the quotes module instead of invoices, obviously.


#13

I am running v1.4.3 and am running into the same issue. My client wants to merge my invoice with the attached details timesheet, but cannot do it because the invoice is secured.

The temporary fix above did not resolve the issue.

Is there a new setting that I am overlooking somewhere?

Your help is greatly appreciated,

Cas


#14

Will be fixed in 1.4.7
https://development.invoiceplane.com/browse/IP-400


closed #16