Unable to install on sub-domain or anydomain


#1

Hello Im trying to install latest Invoiceplane in a subdomain i had made all the changes in ipconfig.php but still it just redirects to 127.0.0.7/index.php/welcome. this should not happen it has to run the sub domain url but it just redirects to localhost can you help me


#2

It would help if you posted your vhost entry and ipconfig,php settings (without the passwords) :grinning:


#3

What Latest InvoicePlane “2” or “1” ?


#4

V1.5.9 in this version if you want i can send you the sub-domain details


#5

V1.5.9 in this version if you want i can send you the sub-domain details


#6

I had tried everything but still its not working if you want i can send you the sub-domain login details


#7

@Neeraj_Kumar, without proper supporting information, it is difficult to assist. Please post the following

  • the web server vhost file for the subdomain
  • the ipconfig file, WITHOUT your database username and passwords
  • the .htaccess file if you have one.
  • An example of a url you are using and what it redirects to

In addition to this, please note that the Welcome controller is listed as the default controller for CodeIgniter, Therefore this might point to an issue in your router config. If you changed the routing table please supply that too.


#9

@Neeraj_Kumar

First, PLEASE DELETE THAT ABOVE POST THAT CONTAINS YOUR USERNAME AND PASSWORD.

Then, edit the file
ipconfig.php
and change the line that contains IP_URL

<?php exit('No direct script access allowed'); ?>
# InvoicePlane Configuration File

### START HERE

             : 
             : 
 IP_URL=http://127.0.0.7                  <<<<<< ======= THIS ONE <<<<<< =======
             : 
             :     

To

IP_URL=http://invoiceplan.epizy.com/

#10

Crafter your not understanding my point
[screenshot remove by admin]
I had done everything but still its not working, please check the screen short


#11

I want you to login by your self and have a look


#12

@Neeraj_Kumar Please read the instructions carefully. In the ipconfig.php file there is an example given how your IP_URL should look like.

Your IP_URL: IP_URL = invoiceplane.epizy.com
What it should look like according to the instruction lines directly above it: IP_URL=http://invoiceplane.epizy.com


Also, deleted your post with the login credentials as well as your screenshot.
I STRONGLY advise you to change all password as your website must now be seen as compromised.


#13

Hello Kovah as you said i had added everything in ipconfig file and i also cleared the history but still the same issue exits. i thing the issue is not from the ipconfig file

<?php exit('No direct script access allowed'); ?>
# InvoicePlane Configuration File

### START HERE

IP_URL= http://invoiceplan.epizy.com

# Having problems? Enable debug by changing the value to 'true' to enable advanced logging
ENABLE_DEBUG=false

# Set this setting to 'true' if you want to disable the setup for security purposes
DISABLE_SETUP=false

# To remove index.php from the URL, set this setting to 'true'.
# Please notice the additional instructions in the htaccess file!
REMOVE_INDEXPHP=false

#14

In that case please get support from your hosting provider. Seems that some configuration is messed up.


#15

@Neeraj_Kumar

Whatever changes you did had an effect. Have a look at the screenshot I posted. In that you can see that I went to the URL http://invoiceplan.epizy.com/index.php/welcome and it did not redirect. It does however say that you have not installed invoiceplane.

Now if you look at the source you will see that it is not seeing the CSS and image files because something is telling it to look at 127.0.0.7 (By the way,localhost is 127.0.0.1). That has to be coming from somewhere (either your ISP or your own files). Track this down and you will have your answer,