Custom PDF Templates - Not Selectable?


Im not sure how it’s supposed to work, but basically i’ve done the following steps, and ended up with no ability to actually choose my new template?

  1. Copied a default template file from the \application\views\invoice_templates\pdf\ directory
  2. Renamed the file ie. custom-invoice.php
  3. Re-uploaded it to the same \application\views\invoice_templates\pdf\
  4. CHMOD 755 (same as all the other template files)
  5. Went into the Settings > Invoice area, and my new template isn’t visible in the drop down list, or any drop down lists?

Where am i going wrong with this? is there somewhere else i need to make a change for the template to be visible to choose? do i have to wait for a cron to happen or something?

Any help would be appreciated :smile:

1 Like

No, any php template that is placed in the \application\views\invoice_templates\pdf\ directory should be available…

It seems to be working for me now, thanks, no idea what it was.

What im not sure about now is how to actually make changes that work, example:

in this section:

<h2 class="invoice-id"><?php echo lang('Tax invoice'); ?> <?php echo $invoice->invoice_number; ?></h2>

But what i’ve done is change ‘invoice’ to ‘Tax invoice’ as thats what they need to be called in Australia, however when using the template, you now don’t even get a label, it just shows the number, so clearly it’s pulling the ‘invoice’ from some kind of variable, but i’ve no idea where that is set?

If you want to use a custom language string just write it down as Tax invoice is not in the language file.

<h2 class="invoice-id">Tax invoice: <?php echo $invoice->invoice_number; ?></h2>
1 Like


One final question then,

On the PDF template, there’s a footer section, is it possible to have the web template read that same footer section and have it on the web template version of the invoice? i can’t see where exactly it’s getting that from?

Also, if you need any help on “Australian” customisation, let me know, as there are a few things which im having to work around because it doesn’t quiet work exactly how the Australian Tax system works.

The footer is inserted by the PDF engine itself.
But it should be possible to display it with the following code (not tested!):

<?php echo $this->mdl_settings->setting('pdf_invoice_footer'); ?>


Just FYI, the reason i ask this, is i’ve used the footer to place an ABN id, which is law in Australia (must display it) obviously it’s not ideal, but it is better than not showing it, but the web template doesn’t show that field… so thats why i asked.


Hi SiriX

We have the same issue here in NZ and here’s my personal work-around.

  1. In Settings > User Accounts, use the Options > Edit to edit your user account. Where it says “VAT ID” put your ABN in here and save your changes.

  2. Go into the file structure of the InvoicePlane files (as you would if you were editing an invoice template) and go to /application/language/english and open the ip_lang.php file to edit it.

  3. Find the line that says 'vat_id_short' => 'VAT', and change it to 'vat_id_short' => 'ABN',

  4. Save the ip-lang.php file and it should now show up on all quotes and invoices correctly.

Note: Save a backup of the ip_lang.php file as it could get overwritten when an InvoicePlane update is being applied…

Thanks for that!

I did notice that in the lang file, but wasn’t sure where it was set… works as you’d want :smile:

Now i’ve got no need for the footer haha!