InvoicePlane 1.5.9 released


#1

A new release of the InvoicePlane application is available: v1.5.9
You can download the latest version from the InvoicePlane website.

Update Guide | Changelog


This is a small release that mainly fixes bugs from the previous versions.

If you want to know more about InvoicePlane 1.5 please visit the original topic.


:beetle: Known bugs in version 1.5.9

  • Import may not work properly (IP-510)

Inmport Problem
#2

#3

Download for Softaculous


#4

Getting this error show up and as code when I attach a PDF to a quote " InvoicePlane - An Error Was Encountered html, html * { box-sizing: border-box; } body { font-family: sans-serif; background: #B94A48; color: #fff; height: 100vh; display: table-cell; vertical-align: middle; text-align: center; padding: 2vh 2vw; } h4 { font-size: 30px; text-align: center; width: 100%; } p { font-size: 16px; width: 100%; }

An Error Was Encountered

The action you have requested is not allowed.

", im the admin and using v1.5.9
Thanks in advance

#5

Please follow the instructions for such errors from the FAQ. Can’t help you otherwise.


#6

Sorry, but IP-687 (Can’t remove clients form user accounts) is still not fixed in 1.5.9
Still get a redirect to a 404 Page Not Found when trying to remove a client when using the delete button.
Deleting a client using the dropdown menu in the overview of all clients does work.


#7

Hello, did you test by reinstalling ip 1.5.9?


#8

Yes, I installed 1.5.9 using the zip-file on github (https://github.com/InvoicePlane/InvoicePlane/archive/v1.5.9.zip)

Did a clean install and configuration, but used my “old” database and my custom invoice pdf templates


#9

First thing don’t use the github file! Download directly from the IP website.

Then run the update procedure, this will update all the relevant SQL tables etc.

Relating to your initial comment…try a full fresh install and see if the issue still occurs.


#10

Could you please verify that the file /application/modules/user_clients/views/field.php looks exactly like this: https://github.com/InvoicePlane/InvoicePlane/blob/master/application/modules/user_clients/views/field.php#L48

The important change is at line 48, there must be a <form> element here. If it’s present it should work.


#11

@nmay1990: Tried your method but same result
Also tried new clean database.
Then added 1 client and tried to remove that client using the delete button. Result: 404 Page Not Found

@Kovah: my local field.php is identical to the one on github


#12

Yes I actually just realized this and while scrolling thru, apparently it’s a known bug. Kovah - do you know if this is logged as a defect?