Installation with nginx

Thank you for the awesome work on the application, it seems really great!

I am tryint to host the application on a web server on digital ocean.
I have followed this guide to set up a LEMP stack on my droplet:

And I have then attempted to follow this guide for installing invoice plane:

However, I am running into a problem when I try to visit the application through my web browser.
I get redirected to /index.php/welcome, but nginx only presents me with a 404 page.

I have verified that php works by creating a test file with phpinfo(); which I could access through the browser and it worked.

Additionaly nginx does not seem to generate any new elines in the error log when I try to access the page.

I have tried many different configs in nginx, but this is what it currently looks like:
(I have also created the ipconfig.php file, and the content is located directly in /var/www/html/)

server {
        listen 80 default_server;
        listen [::]:80 default_server;

        # SSL configuration
        # listen 443 ssl default_server;
        # listen [::]:443 ssl default_server;
        # Note: You should disable gzip for SSL traffic.
        # See:
        # Read up on ssl_ciphers to ensure a secure configuration.
        # See:
        # Self signed certs generated by the ssl-cert package
        # Don't use them in a production server!
        # include snippets/snakeoil.conf;

        root /var/www/html;

        # Add index.php to the list if you are using PHP
        index index.php  index.html index.htm index.nginx-debian.html;

        server_name _;

        location / {
                # First attempt to serve request as file, then
                # as directory, then fall back to displaying a 404.
                try_files $uri $uri/ =404;

        # pass the PHP scripts to FastCGI server listening on
        location ~ \.php$ {
                include snippets/fastcgi-php.conf;

                # With php7.0-cgi alone:
                # fastcgi_pass;
                # With php7.0-fpm:
                fastcgi_pass unix:/run/php/php7.0-fpm.sock;

        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        location ~ /\.ht {
                deny all;

Am I missing anything here?

The following change in my nginx conf seems to have fixed the issue:

                # try_files $uri $uri/ =404;
                try_files $uri $uri/ /index.php?q=$uri&$args;

I guess I have to do some reading up on nginx :slight_smile: