404 error on wordpress


I have copied file via file manager into my web server at e.g. mydomain/qm. I am running wordpress site and new directory qm created by me. I have confusion over .htaccess file, do we need to update that via root access of main directory or we have to update in folder htaccess file? I have updated to both file, tried one by one but still it is not able to installl. Giving error of 404.

RewriteEngine on
RewriteBase /qm
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . index.php [L]

I have changed it like this in both file. Not able to go through first screen.

It shows 404 error and url show http://(mydomai)/qm/welcome (welcome is grayed)

Please help me to understand where am i making mistake.

also let me know if anybody has video of installation on web server?



I am slightly confused by what you’re trying to achieve, wordpress, has nothing to do with IP…however;

You only need to edit the .htaccess file in the root of the IP directory - It looks like you’ve modified the default as it should read:

RewriteEngine On
  RewriteBase /qm
  RewriteRule ^index\.php$ - [L]
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule . /index.php [L]

Having IP in a sub-folder of wordpress shouldn’t be an issue as I actually used to do this. But if you’re struggling why not place the IP installation In a sub-domain of your main site? e.g. qm.yourdomain.com

The installation process is described in the Wiki:

If you’re struggling…You mention ‘File Manager’ are you using cPanel? If so, you could use softaculous to install IP as this is the less technical option.

Hi nmay,

I have inserted above code, but still problem is not solved. Also in .htaccess file it is written that if you are using subfolder, need to remove #, so should i remove that? is that the cause of problem?

Also file manager does comes will many hosting server. I am using ipage none Cpanel hosting. Just fyi.

If couldn’t able to perform installation, will sure go for sub domain, that advice is surely wonderful.



Yes you need to remove the # in front of that line if you’re choosing the subfolder option.

Also make sure the full domain FQDN with subfolder is set in the ipconfig file, for example:


Hope that helps.

Hi Nmay,

Thanks for taking your time and responding me.

below is the error information i got from hosting company.

Uncaught exception ‘Zend_Config_Exception’ with message ‘syntax error, unexpected ‘(’ in ./config/config.ini on line 10
’ in

as per them .index file is creating problem, i have deleted it. still problem persist.

The error log is,

PHP Fatal error: Uncaught exception ‘Zend_Config_Exception’ with message ‘syntax error, unexpected ‘(’ in ./config/config.ini on line 10
’ in /hermes/bosnaweb12a/b1911/(my website address)/library/Zend/Config/Ini.php:181
Stack trace:
#0 /hermes/bosnaweb12a/b1911/(my website address)/quote/library/Zend/Config/Ini.php(201): Zend_Config_Ini->_parseIniFile(’./config/config…’)
#1 /hermes/bosnaweb12a/b1911/(my website address)quote/library/Zend/Confi

index.php is a required file - you can not delete it…doing so will definitely stop IP from working.


as per your instruction, i have uploaded index file. Still there is same problem. Now it is leading me into high curiousity that what is wrong in process? everything as dicribe i have done, still i am getting error of 404. more intrestingly, when i type my url http://mydomain/qm it process and land into http://mydomain/qm/welcome and page shows 404 not found default new wordpress page.

RewriteEngine On
RewriteBase /qm
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

This is what written in .htaccess file

and IP=http://mydomain/qm

what is wrong with me, not able to understand.