Error Number: 1054 MY_Model.php Line Number: 88


#1

Hello. I just upgraded my site to 1.5.5 following the wiki upgrades
After finishing setup successfully. While adding a new client I get this error below but when I go back on the same page and search for the entered client which has given error " entry is saved successfully".

A Database Error Occurred
Error Number: 1054
Unknown column ‘user_all_clients’ in ‘where clause’

SELECT SQL_CALC_FOUND_ROWS ip_users.*FROM ‘ip_users’ WHERE ‘user_all_clients’ = 1 ORDER BY ‘ip_users’.'users_name’
Filename: core/MY_Model.php
Line Number: 88


Database Error Number: 1054
Database Error Number: 1054 - I did search the forum before
#2

Hey,

Had been fixed with v1.5.6
Please upgrade to the last version


#3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.


#4

#5

Hello Everyone, I had to reopen my post because it was closed with the message “Please search the forum before creating a new topic” and the link to another post.

I did seach the forum before, all the say is to upgrade to the latest version, but, I have the latest version and still I got the error. I currently have the version 1.5.9

I have the following error when creating a new client:

#### A Database Error Occurred

Error Number: 1054

Unknown column 'user_all_clients' in 'where clause'

SELECT SQL_CALC_FOUND_ROWS ip_users.* FROM `ip_users` WHERE `user_all_clients` = 1 ORDER BY `ip_users`.`user_name`

Filename: core/MY_Model.php

Line Number: 157

Thank you in advance.


#6

Do you know how to directly access your database with phpmyadmin or a similar tool?

If you can access your database, could you check the table “ip_users” and confirm whether it has a column named “user_all_clients”?

If you cannot find that column in the table, it could be that your database wasn’t correctly updated when you installed v1.5.9. In such cases, reinstalling the software usually fixes the error.


#7

Thank you for your reply, yes I know how to do that, I checked and there is no “user_all_clients”, I understand the quick fix would be a fresh install but I have been using invoice place actively for more tha a year, so I would not want to lose all the info in the databases.

Is there a way to fix the database withoiut losing the info? thanks!!!


#8

there is no “user_all_clients”,

ok, something didn’t go as it should have been when upgrading to v1.5.9

I understand the quick fix would be a fresh install

no, I wasn’t suggesting a fresh-install, I suggested to run again the update process in hopes that this time it would update the database. Of course, make a backup of your database and all files before running the update.

Is there a way to fix the database withoiut losing the info?

Which version were you using before upgrading to v1.5.9? I have read your other posts but cannot find that information and I need it to find out which changes may be required.


#9

To run again the update process follow these instructions:

Make a backup copy of your database (for instance, with phpMyAdmin) or make a duplicate of your database (again, with phpMyAdmin), so that you can recover it if needed.

In the file ‘ipconfig.php’, check this line

# Set this setting to 'true' if you want to disable the setup for security purposes
DISABLE_SETUP=false

and change it to ‘false’ if is set to true

In your browser, go to IP_URL/setup/ to run again the setup of the current version (in your case, v1.5.9), where IP_URL is defined in your ‘ipconfig.php’.


#10

It worked, thank you so much for your help.