Settings page not loading any CSS or JS - IP 1.5.5


#1

Hi there, I’ve installed Invoiceplane 1.5.5 for the first time.
I’m running it on a MAMP stack and everything works fine, except for the system preferences page (index.php/settings) which doesn’t load any CSS or JS.

I’ve tried reinstalling with a different language but it’s still the same.

I couldn’t find this issue with a search on the community: could you please help me to figure it out?
Thank you!


#2

Please check your browser for detailed logs about the asset files and post these logs here. Should be 404 errors if they are not loading.


#3

settings:2 Uncaught ReferenceError: $ is not defined
at settings:2
settings:68 Uncaught ReferenceError: $ is not defined
at settings:68
settings:1890 Uncaught ReferenceError: $ is not defined
at settings:1890

I hope this could be useful… it’s what chrome console prints out on /index.php/settings
Thanks,
Davide


#4

Please make sure, that there are files in the assets/invoiceplane/css folder and they are readable by the web server.


#5

Hi Kovah, thank you for you help.
I downloaded again Invoiceplane 1.5.5 and overwritten the assets/invoiceplane/css folder, but still I’m getting the same error.

Here there is the list of files and permissions I’ve in that folder:
XXX$ ls -l
total 680
-rw-r–r--@ 1 XXX staff 104 29 Ott 11:01 monospace.css
-rw-r–r--@ 1 XXX staff 204 29 Ott 11:01 reports.css
-rw-r–r--@ 1 XXX staff 206509 29 Ott 11:01 style.css
-rw-r–r--@ 1 XXX staff 1326 29 Ott 11:01 templates.css
-rw-r–r--@ 1 XXX staff 124468 29 Ott 11:01 welcome.css

If this error occures to me only, since I found out I need the italian version of Invoiceplane, it could be ignored: maybe something went wrong in my MAMP stack, I don’t know. The italian version runs perfectly.
But still, if you need some help for debugging, I’m waiting to uninstall this version of Invoiceplane.

Thank you!


#6

solved upgrading to invoiceplane 1.5.9 (but I also upgraded php from 5.x to 7.x)