HTTP 500 on setup create user

I have been struggling trying to setup ip for days now everytime I get to the create user form and submit it I get a 500.

Running centos with the latest whm/cpanel php56

Thanks guys :smiley:

Please do so as written in the FAQ, otherwise we can’t help. Also, search the forum as there are several threads regarding such issues.

Just posted the logs

I’ve searched around the forum nothing seemed to work

Is there any logs in applications > logs > date_filename ?

I think that’s from the same time as the apache log let me do it again and see if it changes

Can you see if there is a table named ip_settings in your phpMyAdmin (or whatever) ?

It seems to be a problem with the setup and the database (cannot_connect_database_server)


when I get the 500 the cannot connect must have been from something else when I was playing around

I see people talking about username and passwords for mysql cannot contain special characters.

Mine contain underscores because that’s how cpanel creates them.

Is this a problem?

Underscores should not be a problem. Special characters means ß, æ and something like that. Everythin that is not ASCII.
If your web provider offers something like PhpMyAdmin please try the credentials with this app.

Are you meaning confirm the credentials work?

IP has to connect at some stage because it has created it’s structure

Sure it has to connect.
Please verify that your credentials are correct. Also try different hostnames like instead of localhost just to be sure.

The creds are correct.

I mean IP has already created a schema in the database.

Can you please check that ?

Yep ip_settings is there

Looks like this

Then are you sure your database is called rystuff_ip ? (according to your logs)

It’s renamed now but I deleted everything and re ran the setup and put in the new name and user and password

Also if it wasn’t named correct then it wouldn’t be able to create that ip_settings or any other schemas.

So it’s working now ?

(By the way go in settings change your cron key as we got infos about your domain in the log and you cron key in your screen …)

No it’s still not working

and Thanks if I get it working I will do :slight_smile: