Forgot Password not working in v 1.5.3

I’ve have done a fair amount of reading on this problem and nothing has yet worked, if anyone can offer some insight here I’d be most appreciative!

  1. This installation is running on Ubuntu server 14.04/PHP7.0.21-1
  2. InvoicePlane is installed in subfolder
  3. I have confirmed that php mail function is enabled
  4. I have no error output from apache2 or browser console logs
  5. So far forgot password is the only function that is not working, and the error output on the browser screen says “An error occurred while trying to send your password reset email. Please review the application logs or contact the system administrator.”

Output from application log seems normal to a new guy… I put a paste here
Here is my .htaccess file:

## Run InvoicePlane in a subfolder
## If you are using a subfolder please remove the hash in front of the line ‘#RewriteBase /subfolder’
## and replace ‘subfolder’ with the actual name of your folder, i.e. ‘RewriteBase /invoices’

<IfModule mod_rewrite.c>

  RewriteEngine On
  RewriteBase /ip
  RewriteRule ^index\.php$ - [L]
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule . /index.php [L]

  ## Remove the hash in front of the following two lines if you want to force HTTPS
  #RewriteCond %{HTTPS} off
  #RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]


and finally my ipconfig file:

<?php exit('No direct script access allowed'); ?>
# InvoicePlane Configuration File

# Set your URL without trailing slash here, e.g.
# If you use a subdomain, use
# If you use a subfolder, use

# Having problems? Enable debug by changing the value to 'true' to enable advanced logging

# Set this setting to 'true' if you want to disable the setup for security purposes

# To remove index.php from the URL, set this setting to 'true'.
# Please notice the additional instructions in the htaccess file!

# These database settings are set during the initial setup
DB_USERNAME=(changed to protect the guilty)
DB_PASSWORD=(redacted - althought too late :/)

# If you want to be logged out after closing your browser window, set this setting to 0 (ZERO).
# The number represents the amount of minutes after that IP will automatically log out users,
# the default is 10 days.

# Enable the deletion of invoices

# Disable the read-only mode for invoices

I would be incredibly appreciative for some direction!

Which emailing method do you use? (sendmail? phpmail? smtp?)

Please obfuscate your DB_PASSWORD asap. That’s basic opsec. You should even change it now actually. You might think it’s ok since there is no other relevant info there, but what if I tell you your company’s FB page has 13 likes?

Your config is fine. Problem is your point number 3. Please explain how you verified it.

Well… that was embarrassing! But thanks for letting me know that I got careless! Okay DB user AND pass changed now - let me see if I can recover and move on.

I am using a freshly installed and configured sendmail. Installed just prior to finishing my configuration of InvoicePlane.

HOLD THE PHONE… I got it! I answered a config question wrong! Musa, thank you for all the help man - I think we’re all good here! Looking forward to getting to know the software better and … eh… being a little more careful in the future. I’ll blame lack of coffee if you’ll accept that as an excuse.