Missing 'Currency code' input field

Hello all,

I noticed that in the current IP version 1.5.3 the ‘currency code’ item is missing.
In the previous version 1.4.10 this was still present.
In the settings table, the ‘currency_code’ default value is “USD”.
Can this be added again to the ‘Amount settings panel’ so we can change this default value?

I’m not sure if version 1.5.3 makes any use of this setting anymore (Except for ZUGFERD and SUMEX?).
You can set currency codes individually now, for each online payment gateway, from your “Online Payment” in your /settings page, once you have picked a payment provider.
Why would you need to change this setting?

This setting was used for the PayPal integration but is now deprecated and thus was removed.

As @musa also indicates, this setting is used to create electronic invoices (Zugferd and other country-dependent UBL versions). In these UBL e-invoices, the currency code is a ‘mandatory’ field.
@Kovah: Is it possible to reconsider your decision?

About these electronic invoices:
Companies also trade more and more goods online and beyond their national borders and are therefore looking to use real e-invoices because of the great benefits for themselves and their customers.
For myself and for a few companies, I have modified IP v1.5 so that customer-dependent can be set which e-invoice version they want to use.
Eg an Italian company with customers in Germany, Spain, Belgium or … can set which UBL version is required for its customer. Ie for Germany (Zugferd), for Spain (UBL CCI), for Belgium (UBL eFFF), …
In order to generate these UBL files I use UBL template files.

You just need to add 2-3 lines of HTML code here: /application/modules/settings/views/partial_settings_general.php with get_setting()

I already copied these few lines of code from the previous version, modified it (get_setting() ) and it is working fine.
Thanks for the information.

ah okay, missed the Zugferd implementation. Guess we have to re-add the field.

The UBL attachment thing sounds good, why don’t you share it with the community?