Database white screen in setup

Hi, I have everything installed in a Docker container:

and the setup appears OK until I enter the database info.

After I enter the database info it’s just a white screen.

I’ve verified the information is all correct, what’s the deal?

We need the apache error logs for this. Seems to be a problem that may be not displayed?

Edit: @paralin Can you provide the error logs?

I am also getting the same error. After database info i see a blank screen

I dont have an option to upload error log

@jagadesh Please use paste or a similar service to share such long logs with us.
But these logs doesn’t help us as there are no errors listed. :confused:

Yeah i dont find any errors in logs as well as apache logs. I installed in Cent OS and in sub domain. I verified php, mysql and mcrypt version. Everything looks good. last url i saw in the browser is /setup/configure_database

Please let me know if you need any more details to debug.

Could you please take a look at the database and check if some tables were created?
And check the file /application/config/database.php if there are credentials for your database stored.

I checked database.php, all credentials were stored and no tables were create in database. Its empty

I even tried creating in subdirectory, i see same white screen after i entered database details. No clue in logs too :frowning:

Well that’s weird that there are no logs about this…
Could you please start again from scratch? Delete everything and run the setup again?

Oh yeah i deleted and tried from scratch and even i tried in 2 different domain. I see same white screen after database details…

I even tried loading database table manually, still no luck.

Well at this point I have no clue what the problem could be. I mean if there aren’t any error logs what’s the problem then?

Could you please share your system configuration?

Here is my system configuration

CENTOS 5.11 i686
Apache/2.2.29 (Unix) mod_ssl/2.2.29 OpenSSL/0.9.8e-fips-rhel5 mod_bwlimited/1.4
mcrypt 2.5.8
PHP Version 5.4.38
MySQL : 5.5.42-cll

Had the sam problem

in database.php change driver from mysqli to mysql

p.s. my database is MariaDB 10 :wink: drop in replacement for MySQL and does not have restrictions as MySQL

ok cool… I will give a try. Thanks for your help

@andrej its working… :slight_smile: :slight_smile: :slight_smile: cool… You saved my time… Thanks a ton…

no problem :slight_smile: anytime

What a weird solution. But if its working… Interesting.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.