Aggiornamento da versione 1.4.6


#1

Ciao a tutti!
sto aggiornando dalla versione 1.4.6 alla 1.5.0 come da wiki, ma purtroppo in fase di aggionarmento quando arrivo alla pagina di setup appare il seguente errore:

Fatal error: Can't use function return value in write context in /srv/ip.pixelwise.it/application/modules/setup/controllers/Setup.php on line 329
A PHP Error was encountered

Severity: Compile Error

Message: Can't use function return value in write context

Filename: controllers/Setup.php

Line Number: 329

Backtrace:

controllato i pacchetti minimi richiesti e sono tutti installati correttamente, a qualcuno è sucesso lo stesso?


#2

sembra che la ENCRYPTION_KEY non venga settata al primo aggiornamento… qualcuno ha risolto?


#3

Trovato il problema … ho bypassato il controllo sulla chiave … ed ecco il motivo dell’errore:

La versione PHP installata è la 5.4 ma InvoicePlane richiede la versione 5.6 o successiva