[Solved] After installation and a day, can't login page not found

Looks like a new forum - Hi.

I found this app last night. I have it installed on my debian box (web server, Jessie) in:

I have a wordpress installed in the root, so: /var/www/<wp install>. Only saying this because mod_rewrite is active and my web root has an .htaccess file WP is using. But…

I installed IVP without issue, so I am figuring the root .htaccess WP is using isn’t having an effect on IVP. Moreover, I have a bunch of WP installs and other html in my /projects directory and everything works fine.

As I wrote, I installed the app last night and it was fine. I logged in, set it up a bit, added a couple customers and 1 recurring invoice. emailed it off, too, with success, status changed to sent. So, I was digging the app, thanks for it.

But, this morning I wanted to log back in, add more customers and whatnot, but I cannot. PAGE NOT FOUND. The link I am using is: and it changes to …/ivp/sessions/login and 404’s. I did put authorization on the directory before I tried to login, you know, htpasswd/htaccess, but I removed it because I figured there was a login timeout threshold and I was slow getting my htpasswd creds…but that wasn’t it because I removed it, cleared caches and tried again with the same PAGE NOT FOUND error.

I then renamed my root .htaccess file so that wouldn’t be an issue, repeated the whole cache clearing process and tried to login again and got the same PAGE NOT FOUND error.

So it ain’t that!

I can’t login. I really want to. If anyone has an idea please throw it out there. My next step is to reinstall the app, but that’s a pain in the ass and I can’t do that every time I want to login.


Sounds strange but did you changed the .htaccess file to work with the sub directory?

you want me to change RewriteBase / to RewriteBase /projects/ivp

in my root’s .htaccess?

Not of the root directory. In the .htaccess file of the InvoicePlane folder.

Nevermind. Yes, the root directory of the InvoicePlane app.

I had rewrite on and rewritebase / in that .htaccess file but it didn’t change anything. You have more precise code for me to try? Thanks for your quick responses, by the way.

rewritebase / would point to the Worpdress setup.
You have to point to rewritebase /projects/ivp

I did that, too. Heh, honest. I was just lazy above.

here are the snapshots…

What about the contents of the original .htaccess file? There are some rewrite rules missing.

Lol - what a dope. Know what I did? I’ll tell you - and anyone else can learn from my mistake…

When I added authentication to the .htaccess file I did it the easy way - I copied an .htaccess from another directory. I’m so slick:

sudo cp …/notherproject/.htaccess .

Of course, that overwrote the package’s original .htaccess. Of course I would get an error.

So, I extracted tht original .htaccess from the .zip file the package comes in and replaced the rules. Works fine.

Problem SOLVED. Pebcak the whole way. Thanks for your quick responses Kovah, and thanks for this program.

Marked the issue as solved. :slight_smile: