404 not found on all pages other than index - server change


I just changed server and updated my config file (ubuntu 14 to 16). My installation is under the folder invoice and I can access the page /invoice but I can’t access other pages and get a 404 error not found each time. What could be the problem? Rewrite is enabled.



First: which version do you use?
Second: Did you followed the installation / upgrade instructions and updated your files accordingly?

You can already find a lot of information in the wiki… https://wiki.invoiceplane.com/en/1.5

I was using 1.4.3

I just tried this process but I do not seem to have a ipconfig file :confused:

How shall I proceed?

Thanks for the quick reply again!

I guess you didn’t read anything about the upgrade procedure, right?


I would strongly advise you to restore a backup of your 1.4.3 installation and then follow the guide again.

Maybe I did not go that far down … I’ll give it a shot.

Thanks again!

I have done what was asked in the step and when I connect to https://www.my-domain.com/invoice/index.php/setup I have the following errors:

Warning: unlink(uploads/temp/Quote_for Static OPEC Website.pdf): Permission denied in /var/www/html/connect-james/invoice/index.php on line 102
Your application folder path does not appear to be set correctly. Please open the following file and correct this: index.php

The application path is set correctly to https://www.my-domain.com/invoice

How do you set an application path? It is also wrong… There is no such setting… only the URL in the ipconfig.php file…

Yes that is what I mean I set it like this:


and invoice plane is in the folder called invoice

It seems one of the folders was missing. All solved now. Thanks for the help.