InvoicePlane 1.5.1 released

I have no idea about that. There wasn’t anything changed regarding the payments in 1.5.1.

I have just upgraded to 1.5.1 and have a problem sending emails, I simply get the following and emails are not sent:

It seems that the application stuck because of an error.

Nothing is written to the application/logs when ENABLE_DEBUG=true is set.

I have tried PHP Mail and Sendmail, both are working for other applications on the server.

This might have nothing to do with anything but there are a lot of lines like this in the log:

ERROR - 2017-05-01 22:52:17 --> Could not find the language line "enabled"

Did you re-entered the credentials for SMTP?

Did you re-entered the credentials for SMTP?

No I haven’t been using authenticated SMTP, I been using /usr/sbin/sendmail (in this case Exim), I also tried PHP Mail, but neither worked, I could look at setting up unauthenticated SMPT on the localhost if needs be.


Generated Reports (and viewing other PDF files like Invoices or Quotes): I agree that opening these types of pdf files on top of the same browser window is not the best solution. Opening another tab or browser window is good, but I prefer this type of view into a modal window and so you do not have to leave the same page/window.
@Kovah: Is it possible to add an additional option in “General settings” to view PDFs in a modal window OR in a new tab/window?

Good morning. Thank you for the updates.
Right now, Created clean DB, unzipped files, duplicated and renamed the ipconfig file, added the subdomain to the ip url line (without the trailing slash) and when I try to start the setup I get the below error.

Please note that:

  1. My setup is pretty simple. Cpanel. I’m using a subdomain for InvoicePlane. This is a clean install.
  2. I installed 1.4 version using a subdomain also, clean db, etc. And I’ve been using it for months now, working perfectly.
  3. I’m using these Installation steps
  4. I already downloaded the latest version online
  5. I see the welcome screen, When I click the green setup button I get the error.

In my cpanel, Same environment and permissions as my current 1.4 installation just different folder name. Any clues?

Fatal error: Can't use function return value in write context in /home/-----/public_html/test-environ/bill15/application/modules/setup/controllers/Setup.php on line 338
A PHP Error was encountered

Severity: Warning

Message: Cannot modify header information - headers already sent by (output started at /home/-----/public_html/test-environ/bill15/application/modules/setup/controllers/Setup.php:338)

Filename: core/Common.php

Line Number: 564


A PHP Error was encountered

Severity: Compile Error

Message: Can't use function return value in write context

Filename: controllers/Setup.php

Line Number: 338


In order to make sure that email was working on the server I used this script via the command line and via HTTPS to send emails via PHP Mail and both worked without an issue.

After a quick look I couldn’t find a simple script to test /usr/sbin/sendmail via a PHP script so I simply tested it via the command line:

echo "Test of sendmail" | /usr/sbin/sendmail -v

There are no problems sending email via PHP Mail or /usr/sbin/sendmail as far as I can tell on the servers I’m using for hosting, however as mentioned above I haven’t been able to send any emails using either of these methods using Invoice Plane 1.5.1. Next week I might have some time to do some testing of unauthenticated SMTP via localhost.

The problem does not exist at previous version, but once i update the invoice plane to 1.5.1, the software will show up duplicated invoice (in dashboard or viewing invoice section) if i make two partial payments on the same invoice. It causes the invoice overdue showing wrong/duplicate amount.

Thanks for the report, added a ticket for that.

Hi I am trying to update from version v1.4.6 to 1.51. Following this guide: I am following this portion of upgrading “Additional steps for specific versions” This is the error that comes up:

A PHP Error was encountered

Severity: Notice

Message: Undefined property: CI::$mdl_settings

Filename: helpers/trans_helper.php

Line Number: 82


File: invoiceplane/application/helpers/trans_helper.php
Line: 82
Function: _error_handler

File: invoiceplane/application/helpers/trans_helper.php
Line: 31
Function: reset_language

File: invoiceplane/application/modules/setup/controllers/Setup.php
Line: 268
Function: trans

Line: 212
Function: check_database

File: /invoiceplane/index.php
Line: 334
Function: require_once
Fatal error: Call to a member function setting() on null in /application/helpers/trans_helper.php on line 82
A PHP Error was encountered

Severity: Error

Message: Call to a member function setting() on null

Filename: helpers/trans_helper.php

Line Number: 82


What do I put for line 82??? $default_lang = $CI->mdl_settings->setting(‘default_language’); do I change default language to english? or put en?. I selected en from the drop down and clicked next and thats what happened.


Please wait for 1.5.2 instead of changing any files.

thank you i will revert and stay on 1.46 and try again when 1.5.2 is released. Would I follow the same guide? when upgrading or is it a simpler method?. Its been a while since ive used invoiceplane and I eventually need to get it up and running and hopefully migrate all my fusion invoice information over to it =)

You upgrade to 1.5.2 the same way you upgrade to 1.5.0. please follow the upgrade guide in the wiki.

ok so pretty much what I was following. IS there any approximation as to when 1.5.2 will be released?.


After upgrading from a much older version (1.1) i got the following error:

Was able to fix this by renaming the folder (application/language) of the selected language (during setup) to non-capital. E.g. Dutch to dutch.

I’m having an issue on this version, which used to work.
When I’m generating a PDF from an invoice or quote, I keep getting the following error:

Parse error: syntax error, unexpected ‘/’, expecting ‘,’ or ‘;’ in /home/techbis170/domains/ on line 51
A PHP Error was encountered

Severity: Warning

Message: Cannot modify header information - headers already sent by (output started at /home/techbis170/domains/

Filename: core/Common.php

Line Number: 570


A PHP Error was encountered

Severity: Parsing Error

Message: syntax error, unexpected ‘/’, expecting ‘,’ or ‘;’

Filename: src/Mpdf.php

Line Number: 51


It used to work when I had just upgraded to 1.5.1, but my server provided recently did a shift to another, newer server. It stopped working after that
Could it be related to that?

I’ve already reuploaded the whole invoiceplane program to the server, did no difference.

EDIT: Nvm, I fixed it. Apparently when they did the move, they changed the PHP version back to 5.5 instead of 7.
I’ve changed it back to 7 and this fixed it.

I made the upgrade and I have found an issue with Custom Fields which contains accentuated characters…
To make them works, I had to rename custom_field_label on the database to remove all accentuated character

Could you specify where you exactly got these problems? All accents should be properly escaped.

Topic is now closed. Please redirect all issues to the topic for version 1.5.2.