"404: File Not Found" when upgrading to v1.4.10

I’ve followed every other thread with this issue and nothing is working for me.

I’ve changed my url in my index.php, define(‘IP_URL’, ‘http://mydomain.com/invoices/’);

Removed “index.php” from my config.php file.

I’ve htaccess files reads:

RewriteEngine on
RewriteBase /invoices
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . index.php [L]

When I navigate to http://mydomain.com/invoices/index.php/setup it redirects to an IP address /invoices/index.php/setup/language

Any help would be much appreciated.

You may try http://mydomain.com/invoices/setup

If that doesn’t work: did you tried that without the .htaccess?

Any follow up to this?

If you delete the .Htaccess and open http://my domain.com/invoices/index.php/setup you get redirected to http://my domain.com?

Yes. The URL says http://my domain.com/invoices/setup/language/ but what is displayed is http://my domain.com

This URL is not working if you delete the .htaccess file.
It must be http://my domain.com/invoices/index.php/setup/language/ then.

Making a little progress. I see this, but when I click ‘Continue’ it redirects http://my domain.com/invoices/setup/language but then what is displayed is http://my domain.com

This is very weird.
Are you sure that you deleted the .htaccess file completely? If yes, try clearing the browser cache. Something must intefere with the URLs…

Tried installing the beta and then http://my domain.com/invoices/index.php/setup/language/

Then I see

But it exists with proper write permissions

Maybe recreate it and double check the permissions. The folder needs to be writeable for the web server (writeable for everyone).

Still doesn’t work

Finally got through most of the set up and then received this:

A Database Error Occurred

Error Number: 1118

Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs

CREATE TABLE ip_client_custom_new ( client_custom_id INT NOT NULL PRIMARY KEY AUTO_INCREMENT , client_id INT NOT NULL, client_custom_fieldid INT NOT NULL, client_custom_fieldvalue VARCHAR(65535) NULL , UNIQUE (client_id, client_custom_fieldid) );

Filename: modules/setup/models/Mdl_setup.php

Line Number: 265

The error implicates that you are using an older version of the beta. This statement was removed long ago. Please try again with the latest version.