404 Not Found error (updating 1.4.7 > 1.4.10)


I am trying to update my InvoicePlane version from 1.4.7 to 1.4.10 and I have followed the instructions on https://wiki.invoiceplane.com/en/1.0/getting-started/updating-ip but everytime I try to access www.my-domain.co.uk/setup/ I get a 404 Not Found error.

Why is this and how can I fix it?


Have you setup your URL in index.php in the root of your directory ?
What"s in your .htaccess at the root too ?


Thank you for replying…

I have setup the URL in the index.php file. Attached is a link to my .htaccess file…



Can you please try with the .htaccess in this link : https://wiki.invoiceplane.com/en/1.0/getting-started/installation
Moreover on your actual .htaccess you have setup the RewriteBase to /accounts I suggest you install InvoicePlane in a sub-folder right ?
Be sure to double-check the index.php file to setup the URL of your installation with the sub-folder too :slight_smile:

You legend!

Just to confirm for anyone else that has the same issue, I have attached the link to my updated .htaccess file…


Thank you very much for your help Maxime, I used the .htaccess file located at the bottom of the page you linked me too and that has fixed it. I’m now running 1.4.10.

Do you have any idea why Redirect /setup http://my-domain.co.uk/ is not working? I can still access the setup directory?

My redirect setup is like this

Redirect /setup http://my-domain.co.uk/

(it seems the same as you in your pastebin)

Try to add the Redirect at the end of your .htaccess and see if it works :slight_smile:

Tried that. Could it be some kind of server setting?


You have setup correctly the URL to redirect ?

I used this instead:
Redirect 301 /accounts/setup http://my-domain.co.uk

And does it works ?

I wasn’t forced to specify 301
But whatever try with and without
And try
Redirect /setup http://my-domain.co.uk/accounts/

By the way be sure to specify the / after the URL (with or without sub-folder)

It has worked. :slight_smile: Thank you so much for helping!

1 Like