[Solved] Installation Error (.htaccess)

I can’t seems to install InvP, I have read the documentation but no luck, any help will be greatly appreciated.

Machine : VBox Ubuntu 14.04 2Gb ram
Software: LAMP deployed tested ok
MOD_REWRITE : installed OK
MYSQL DB: invoicep (created and tested ok)
.htaccess : Copied ok Content is:

Remove index.php

RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . index.php [L]

Apache default location: /var/www/html
Inv Plane software location: /var/www/html/


Error description:
When accessing web page /setup I get the following error:
404 Not Found
The requested URL /setup was not found on this server.

Extra Info:
application/ and uploads/ folders were given 755 privileges.

At this web browser location: http://localhost/index.php/setup/language
I get a screen " Invoice Plane" Choose Language…
However pressing Continue display same error as above.


  1. Are there any settings required to be entered on the files, before running the setup?
  2. Where are the log files for InvPlane after installation errors
  3. Is there any security issues to be resolved (check) at MYSQL to start install?
  4. By the look at the installation instructions, this seems very easy task, what are the suggestions or steps to ensure a correct installation?
  5. Finally, can somebody supply the settings required for a successful installation

Best Regards

It looks like mod_rewrite is not installed/activated. This can be fixed by running “sudo a2enmod rewrite && sudo service apache2 restart” on ubuntu. If this returns an error, the rewrite package might not be installed. There might also be a wrong configuration in the apache config regarding AllowOverride.

Hi lommes,
Thank you for replying. I have re-checked “sudo a2enmod rewrite” and the answer is “Module rewrite already enabled”, so I don’t think is that one.

In regards to:
“There might also be a wrong configuration in the apache config regarding AllowOverride.”

I have checked the /etc/apache2/apache2.conf file and this is the setting for /var/www/ inside:

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride None
Require all granted

Not sure this is wrong.

Any other suggestion will be welcome


Hi There,
I have changed the setting on /etc/apache2/apache2.con to

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted

and voila, the installation proceed to Prerequisites. Thanks for the tip.


This topic was automatically closed after 2 days. New replies are no longer allowed.